summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--community/docutils/PKGBUILD5
-rw-r--r--community/python-apipkg/PKGBUILD1
-rw-r--r--community/python-atomicwrites/PKGBUILD1
-rw-r--r--community/python-babel/PKGBUILD1
-rw-r--r--community/python-cachecontrol/PKGBUILD1
-rw-r--r--community/python-colorama/PKGBUILD5
-rw-r--r--community/python-distlib/PKGBUILD1
-rw-r--r--community/python-distro/PKGBUILD3
-rw-r--r--community/python-html5lib/PKGBUILD1
-rw-r--r--community/python-imagesize/PKGBUILD5
-rw-r--r--community/python-iniconfig/PKGBUILD1
-rw-r--r--community/python-jinja/PKGBUILD5
-rw-r--r--community/python-lockfile/PKGBUILD1
-rw-r--r--community/python-mock/PKGBUILD2
-rw-r--r--community/python-more-itertools/PKGBUILD4
-rw-r--r--community/python-msgpack/PKGBUILD1
-rw-r--r--community/python-ndg-httpsclient/PKGBUILD5
-rw-r--r--community/python-pbr/PKGBUILD1
-rw-r--r--community/python-pluggy/PKGBUILD1
-rw-r--r--community/python-progress/PKGBUILD5
-rw-r--r--community/python-py/PKGBUILD1
-rw-r--r--community/python-pygments/PKGBUILD5
-rw-r--r--community/python-pysocks/PKGBUILD6
-rw-r--r--community/python-pytest/PKGBUILD2
-rw-r--r--community/python-pytoml/PKGBUILD5
-rw-r--r--community/python-pytz/PKGBUILD5
-rw-r--r--community/python-snowballstemmer/PKGBUILD5
-rw-r--r--community/python-sphinx-alabaster-theme/PKGBUILD5
-rw-r--r--community/python-sphinx/PKGBUILD5
-rw-r--r--community/python-sphinx_rtd_theme/PKGBUILD5
-rw-r--r--community/python-sphinxcontrib-websupport/PKGBUILD5
-rw-r--r--community/python-sqlalchemy/PKGBUILD1
-rw-r--r--community/python-webencodings/PKGBUILD1
-rw-r--r--community/python-whoosh/PKGBUILD1
-rw-r--r--community/python2-enum34/PKGBUILD5
-rw-r--r--community/python2-funcsigs/PKGBUILD1
-rw-r--r--community/python2-pathlib2/PKGBUILD5
-rw-r--r--community/python2-scandir/PKGBUILD5
-rw-r--r--community/python2-typing/PKGBUILD5
-rw-r--r--extra/pyopenssl/PKGBUILD1
-rw-r--r--extra/python-appdirs/PKGBUILD5
-rw-r--r--extra/python-asn1crypto/PKGBUILD5
-rw-r--r--extra/python-attrs/PKGBUILD1
-rw-r--r--extra/python-cffi/PKGBUILD1
-rw-r--r--extra/python-chardet/PKGBUILD5
-rw-r--r--extra/python-cryptography/PKGBUILD1
-rw-r--r--extra/python-idna/PKGBUILD4
-rw-r--r--extra/python-markupsafe/PKGBUILD5
-rw-r--r--extra/python-packaging/PKGBUILD1
-rw-r--r--extra/python-pip/PKGBUILD4
-rw-r--r--extra/python-ply/PKGBUILD5
-rw-r--r--extra/python-pyasn1/PKGBUILD5
-rw-r--r--extra/python-pycparser/PKGBUILD5
-rw-r--r--extra/python-pyparsing/PKGBUILD3
-rw-r--r--extra/python-requests/PKGBUILD1
-rw-r--r--extra/python-retrying/PKGBUILD5
-rw-r--r--extra/python-setuptools/PKGBUILD1
-rw-r--r--extra/python-six/PKGBUILD1
-rw-r--r--extra/python-urllib3/PKGBUILD2
-rw-r--r--extra/python2-ipaddress/PKGBUILD5
60 files changed, 184 insertions, 5 deletions
diff --git a/community/docutils/PKGBUILD b/community/docutils/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/docutils/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/community/python-apipkg/PKGBUILD b/community/python-apipkg/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/community/python-apipkg/PKGBUILD
+++ b/community/python-apipkg/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python-atomicwrites/PKGBUILD b/community/python-atomicwrites/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/community/python-atomicwrites/PKGBUILD
+++ b/community/python-atomicwrites/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python-babel/PKGBUILD b/community/python-babel/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/community/python-babel/PKGBUILD
+++ b/community/python-babel/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python-cachecontrol/PKGBUILD b/community/python-cachecontrol/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/community/python-cachecontrol/PKGBUILD
+++ b/community/python-cachecontrol/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python-colorama/PKGBUILD b/community/python-colorama/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/python-colorama/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/community/python-distlib/PKGBUILD b/community/python-distlib/PKGBUILD
index 870e034f..bd57ba9d 100644
--- a/community/python-distlib/PKGBUILD
+++ b/community/python-distlib/PKGBUILD
@@ -1,5 +1,6 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
# currently tests are failing, they are disabled not due to dependencies
unset check
fi
diff --git a/community/python-distro/PKGBUILD b/community/python-distro/PKGBUILD
index 32d99307..416ab6ac 100644
--- a/community/python-distro/PKGBUILD
+++ b/community/python-distro/PKGBUILD
@@ -1,5 +1,8 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+
# disable sphinx for now, needs too many packages
makedepends=(${makedepends[@]//python-sphinx/})
makedepends=(${makedepends[@]//python2-sphinx/})
diff --git a/community/python-html5lib/PKGBUILD b/community/python-html5lib/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/community/python-html5lib/PKGBUILD
+++ b/community/python-html5lib/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python-imagesize/PKGBUILD b/community/python-imagesize/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/python-imagesize/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/community/python-iniconfig/PKGBUILD b/community/python-iniconfig/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/community/python-iniconfig/PKGBUILD
+++ b/community/python-iniconfig/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python-jinja/PKGBUILD b/community/python-jinja/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/python-jinja/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/community/python-lockfile/PKGBUILD b/community/python-lockfile/PKGBUILD
index e50d2ff2..1c6c782d 100644
--- a/community/python-lockfile/PKGBUILD
+++ b/community/python-lockfile/PKGBUILD
@@ -1,5 +1,6 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
makedepends+=('python-pbr' 'python2-pbr')
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python-mock/PKGBUILD b/community/python-mock/PKGBUILD
index e50d2ff2..22a68305 100644
--- a/community/python-mock/PKGBUILD
+++ b/community/python-mock/PKGBUILD
@@ -1,5 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
- makedepends+=('python-pbr' 'python2-pbr')
+ makedepends+=('python-pbr' 'python2-pbr' 'python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python-more-itertools/PKGBUILD b/community/python-more-itertools/PKGBUILD
new file mode 100644
index 00000000..3b5f7de0
--- /dev/null
+++ b/community/python-more-itertools/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+fi
diff --git a/community/python-msgpack/PKGBUILD b/community/python-msgpack/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/community/python-msgpack/PKGBUILD
+++ b/community/python-msgpack/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python-ndg-httpsclient/PKGBUILD b/community/python-ndg-httpsclient/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/python-ndg-httpsclient/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/community/python-pbr/PKGBUILD b/community/python-pbr/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/community/python-pbr/PKGBUILD
+++ b/community/python-pbr/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python-pluggy/PKGBUILD b/community/python-pluggy/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/community/python-pluggy/PKGBUILD
+++ b/community/python-pluggy/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python-progress/PKGBUILD b/community/python-progress/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/python-progress/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/community/python-py/PKGBUILD b/community/python-py/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/community/python-py/PKGBUILD
+++ b/community/python-py/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python-pygments/PKGBUILD b/community/python-pygments/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/python-pygments/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/community/python-pysocks/PKGBUILD b/community/python-pysocks/PKGBUILD
index 20354d08..e05c2c4b 100644
--- a/community/python-pysocks/PKGBUILD
+++ b/community/python-pysocks/PKGBUILD
@@ -1,3 +1,9 @@
# check() is disabled
unset checkdepends
+unset check
+
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+fi
diff --git a/community/python-pytest/PKGBUILD b/community/python-pytest/PKGBUILD
index 6c63d86f..f06df55f 100644
--- a/community/python-pytest/PKGBUILD
+++ b/community/python-pytest/PKGBUILD
@@ -1,5 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
- makedepends+=('python-setuptools-scm' 'python2-setuptools-scm')
+ makedepends+=('python-setuptools-scm' 'python2-setuptools-scm' 'python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python-pytoml/PKGBUILD b/community/python-pytoml/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/python-pytoml/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/community/python-pytz/PKGBUILD b/community/python-pytz/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/python-pytz/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/community/python-snowballstemmer/PKGBUILD b/community/python-snowballstemmer/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/python-snowballstemmer/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/community/python-sphinx-alabaster-theme/PKGBUILD b/community/python-sphinx-alabaster-theme/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/python-sphinx-alabaster-theme/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/community/python-sphinx/PKGBUILD b/community/python-sphinx/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/python-sphinx/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/community/python-sphinx_rtd_theme/PKGBUILD b/community/python-sphinx_rtd_theme/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/python-sphinx_rtd_theme/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/community/python-sphinxcontrib-websupport/PKGBUILD b/community/python-sphinxcontrib-websupport/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/python-sphinxcontrib-websupport/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/community/python-sqlalchemy/PKGBUILD b/community/python-sqlalchemy/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/community/python-sqlalchemy/PKGBUILD
+++ b/community/python-sqlalchemy/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python-webencodings/PKGBUILD b/community/python-webencodings/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/community/python-webencodings/PKGBUILD
+++ b/community/python-webencodings/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python-whoosh/PKGBUILD b/community/python-whoosh/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/community/python-whoosh/PKGBUILD
+++ b/community/python-whoosh/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python2-enum34/PKGBUILD b/community/python2-enum34/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/python2-enum34/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/community/python2-funcsigs/PKGBUILD b/community/python2-funcsigs/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/community/python2-funcsigs/PKGBUILD
+++ b/community/python2-funcsigs/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python2-pathlib2/PKGBUILD b/community/python2-pathlib2/PKGBUILD
new file mode 100644
index 00000000..6c63d86f
--- /dev/null
+++ b/community/python2-pathlib2/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-setuptools-scm' 'python2-setuptools-scm')
+ unset check
+fi
diff --git a/community/python2-scandir/PKGBUILD b/community/python2-scandir/PKGBUILD
new file mode 100644
index 00000000..6c63d86f
--- /dev/null
+++ b/community/python2-scandir/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-setuptools-scm' 'python2-setuptools-scm')
+ unset check
+fi
diff --git a/community/python2-typing/PKGBUILD b/community/python2-typing/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/python2-typing/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/extra/pyopenssl/PKGBUILD b/extra/pyopenssl/PKGBUILD
index aa4776cc..4f2a85bf 100644
--- a/extra/pyopenssl/PKGBUILD
+++ b/extra/pyopenssl/PKGBUILD
@@ -1,5 +1,6 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
unset -f pkgver
diff --git a/extra/python-appdirs/PKGBUILD b/extra/python-appdirs/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/extra/python-appdirs/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/extra/python-asn1crypto/PKGBUILD b/extra/python-asn1crypto/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/extra/python-asn1crypto/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/extra/python-attrs/PKGBUILD b/extra/python-attrs/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/extra/python-attrs/PKGBUILD
+++ b/extra/python-attrs/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/extra/python-cffi/PKGBUILD b/extra/python-cffi/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/extra/python-cffi/PKGBUILD
+++ b/extra/python-cffi/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/extra/python-chardet/PKGBUILD b/extra/python-chardet/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/extra/python-chardet/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/extra/python-cryptography/PKGBUILD b/extra/python-cryptography/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/extra/python-cryptography/PKGBUILD
+++ b/extra/python-cryptography/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/extra/python-idna/PKGBUILD b/extra/python-idna/PKGBUILD
new file mode 100644
index 00000000..3b5f7de0
--- /dev/null
+++ b/extra/python-idna/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+fi
diff --git a/extra/python-markupsafe/PKGBUILD b/extra/python-markupsafe/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/extra/python-markupsafe/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/extra/python-packaging/PKGBUILD b/extra/python-packaging/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/extra/python-packaging/PKGBUILD
+++ b/extra/python-packaging/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/extra/python-pip/PKGBUILD b/extra/python-pip/PKGBUILD
index 55d77113..470a12fe 100644
--- a/extra/python-pip/PKGBUILD
+++ b/extra/python-pip/PKGBUILD
@@ -1,8 +1,6 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
- md5sums[1]='71cb8b43efaa6af0d6cd98576ca2f932'
- sha256sums[1]='ff81c9d48be20765145cb04953c54c5b9059bd193e3d82cec870d3391e6e6dd1'
-
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/extra/python-ply/PKGBUILD b/extra/python-ply/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/extra/python-ply/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/extra/python-pyasn1/PKGBUILD b/extra/python-pyasn1/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/extra/python-pyasn1/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/extra/python-pycparser/PKGBUILD b/extra/python-pycparser/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/extra/python-pycparser/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/extra/python-pyparsing/PKGBUILD b/extra/python-pyparsing/PKGBUILD
index 7f88e0ac..e9913b6a 100644
--- a/extra/python-pyparsing/PKGBUILD
+++ b/extra/python-pyparsing/PKGBUILD
@@ -1,5 +1,8 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+
# subversion introduces a crazy amount of build dependencies, take
# official tarball
makedepends=(${makedepends[@]//subversion/})
diff --git a/extra/python-requests/PKGBUILD b/extra/python-requests/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/extra/python-requests/PKGBUILD
+++ b/extra/python-requests/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/extra/python-retrying/PKGBUILD b/extra/python-retrying/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/extra/python-retrying/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/extra/python-setuptools/PKGBUILD b/extra/python-setuptools/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/extra/python-setuptools/PKGBUILD
+++ b/extra/python-setuptools/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/extra/python-six/PKGBUILD b/extra/python-six/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/extra/python-six/PKGBUILD
+++ b/extra/python-six/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/extra/python-urllib3/PKGBUILD b/extra/python-urllib3/PKGBUILD
index f7e86cb1..2175b900 100644
--- a/extra/python-urllib3/PKGBUILD
+++ b/extra/python-urllib3/PKGBUILD
@@ -1,5 +1,7 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+
# disable sphinx for now, needs too many packages
makedepends=(${makedepends[@]//python2-sphinx/})
diff --git a/extra/python2-ipaddress/PKGBUILD b/extra/python2-ipaddress/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/extra/python2-ipaddress/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi