summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-02-21 14:48:05 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2021-02-21 14:48:05 +0100
commitceef2151313d5dd543c0fc76ecd27477166cd527 (patch)
treef173bebd46c33cfdf87ee9d78d906b3f199ae67c /community
parente532b07db17a26409c6c8b1e63a90566f018f83d (diff)
downloadpackages-ceef2151313d5dd543c0fc76ecd27477166cd527.tar.xz
build-support/libvips884: added for building sharp in npm
Diffstat (limited to 'community')
-rw-r--r--community/npm/PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/community/npm/PKGBUILD b/community/npm/PKGBUILD
new file mode 100644
index 0000000..6d0e5a5
--- /dev/null
+++ b/community/npm/PKGBUILD
@@ -0,0 +1,22 @@
+# we put in libvips though upstream PKGBUILD says:
+# "libvips: for sharp (doc build) (disabled as current version of gatsby imports a broken sharp)"
+# I seem unable to be able to build anything useful if the libvips is absent from the makedepends
+#
+# https://github.com/lovell/sharp/issues/2023
+#
+#ERR! sharp Intel Architecture 32-bit systems require manual installation of libvips >= 8.8.1
+#info sharp Attempting to build from source via node-gyp but this may fail due to the above error
+#info sharp Please see https://sharp.pixelplumbing.com/page/install for required dependencies
+#make[1]: Entering directory '/build/npm/src/cli-6.14.11/docs/node_modules/sharp/build'
+# TOUCH Release/obj.target/libvips-cpp.stamp
+# CXX(target) Release/obj.target/sharp/src/common.o
+#../src/common.cc:25:10: fatal error: vips/vips8: No such file or directory
+# 25 | #include <vips/vips8>
+# | ^~~~~~~~~~~~
+#
+# most likely there is a binary version available, so sharp has not to be rebuilt (as on IA-32)
+makedepends+=(libvips)
+
+# https://github.com/lovell/sharp/issues/2023
+#gatsby-plugin-manifest ERROR #11321 Error: Input file contains unsupported image format
+#