summaryrefslogtreecommitdiff
path: root/community/npm/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/npm/PKGBUILD')
-rw-r--r--community/npm/PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/community/npm/PKGBUILD b/community/npm/PKGBUILD
new file mode 100644
index 00000000..6d0e5a5a
--- /dev/null
+++ b/community/npm/PKGBUILD
@@ -0,0 +1,22 @@
+# we put in libvips though upstream PKGBUILD says:
+# "libvips: for sharp (doc build) (disabled as current version of gatsby imports a broken sharp)"
+# I seem unable to be able to build anything useful if the libvips is absent from the makedepends
+#
+# https://github.com/lovell/sharp/issues/2023
+#
+#ERR! sharp Intel Architecture 32-bit systems require manual installation of libvips >= 8.8.1
+#info sharp Attempting to build from source via node-gyp but this may fail due to the above error
+#info sharp Please see https://sharp.pixelplumbing.com/page/install for required dependencies
+#make[1]: Entering directory '/build/npm/src/cli-6.14.11/docs/node_modules/sharp/build'
+# TOUCH Release/obj.target/libvips-cpp.stamp
+# CXX(target) Release/obj.target/sharp/src/common.o
+#../src/common.cc:25:10: fatal error: vips/vips8: No such file or directory
+# 25 | #include <vips/vips8>
+# | ^~~~~~~~~~~~
+#
+# most likely there is a binary version available, so sharp has not to be rebuilt (as on IA-32)
+makedepends+=(libvips)
+
+# https://github.com/lovell/sharp/issues/2023
+#gatsby-plugin-manifest ERROR #11321 Error: Input file contains unsupported image format
+#