summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-02-21 14:48:05 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2021-02-21 14:48:05 +0100
commitceef2151313d5dd543c0fc76ecd27477166cd527 (patch)
treef173bebd46c33cfdf87ee9d78d906b3f199ae67c
parente532b07db17a26409c6c8b1e63a90566f018f83d (diff)
downloadpackages-ceef2151313d5dd543c0fc76ecd27477166cd527.tar.xz
build-support/libvips884: added for building sharp in npm
-rw-r--r--build-support/libvips884/PKGBUILD24
-rw-r--r--community/npm/PKGBUILD22
2 files changed, 46 insertions, 0 deletions
diff --git a/build-support/libvips884/PKGBUILD b/build-support/libvips884/PKGBUILD
new file mode 100644
index 00000000..c73ac6fb
--- /dev/null
+++ b/build-support/libvips884/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+
+pkgname=libvips884
+pkgver=8.8.4
+pkgrel=1
+pkgdesc="A fast image processing library with low memory needs"
+arch=(i486 i686 pentium4 'x86_64')
+license=('LGPL')
+url="https://libvips.github.io/libvips/"
+depends=('cfitsio' 'fftw' 'imagemagick' 'libexif' 'libgsf' 'libheif' 'libimagequant' 'librsvg'
+ 'libwebp' 'libxml2' 'openexr' 'orc' 'pango' 'poppler-glib')
+source=("https://github.com/libvips/libvips/releases/download/v$pkgver/vips-$pkgver.tar.gz")
+sha512sums=('d65eb9ce009ee0d23e3cb958ed255414ca422c3db11362afb2cd88fe82062f2ed87ac1eb80993130c35fb8e70bb297faa9f12a37faa7f3628ea8df2a26112d11')
+
+build() {
+ cd vips-$pkgver
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd vips-$pkgver
+ make DESTDIR="$pkgdir" install
+}
diff --git a/community/npm/PKGBUILD b/community/npm/PKGBUILD
new file mode 100644
index 00000000..6d0e5a5a
--- /dev/null
+++ b/community/npm/PKGBUILD
@@ -0,0 +1,22 @@
+# we put in libvips though upstream PKGBUILD says:
+# "libvips: for sharp (doc build) (disabled as current version of gatsby imports a broken sharp)"
+# I seem unable to be able to build anything useful if the libvips is absent from the makedepends
+#
+# https://github.com/lovell/sharp/issues/2023
+#
+#ERR! sharp Intel Architecture 32-bit systems require manual installation of libvips >= 8.8.1
+#info sharp Attempting to build from source via node-gyp but this may fail due to the above error
+#info sharp Please see https://sharp.pixelplumbing.com/page/install for required dependencies
+#make[1]: Entering directory '/build/npm/src/cli-6.14.11/docs/node_modules/sharp/build'
+# TOUCH Release/obj.target/libvips-cpp.stamp
+# CXX(target) Release/obj.target/sharp/src/common.o
+#../src/common.cc:25:10: fatal error: vips/vips8: No such file or directory
+# 25 | #include <vips/vips8>
+# | ^~~~~~~~~~~~
+#
+# most likely there is a binary version available, so sharp has not to be rebuilt (as on IA-32)
+makedepends+=(libvips)
+
+# https://github.com/lovell/sharp/issues/2023
+#gatsby-plugin-manifest ERROR #11321 Error: Input file contains unsupported image format
+#