summaryrefslogtreecommitdiff
path: root/extra/tbb
diff options
context:
space:
mode:
Diffstat (limited to 'extra/tbb')
-rw-r--r--extra/tbb/PKGBUILD34
-rw-r--r--extra/tbb/oneTBB-2021.5.0-no-waitpkg.patch12
2 files changed, 46 insertions, 0 deletions
diff --git a/extra/tbb/PKGBUILD b/extra/tbb/PKGBUILD
new file mode 100644
index 00000000..6ddbb31c
--- /dev/null
+++ b/extra/tbb/PKGBUILD
@@ -0,0 +1,34 @@
+# disable waitpkg extensions (error is inline failing in _tpause)
+# (see https://github.com/oneapi-src/oneTBB/issues/370 and
+# https://github.com/oneapi-src/oneTBB/pull/609/commits/542a27fa1cfafaf76772e793549d9f4d288d03a9)
+source+=('oneTBB-2021.5.0-no-waitpkg.patch')
+sha512sums+=('0050970336052909d0572514bb88b8ca12210224bec1245f1c05423f1a8e6e28a5048cc06f969efd81f2de14d342f69641cdfbf9f82ad8e41ca618ae4ce16f16')
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() { cd ${srcdir}/oneTBB-${pkgver}\n}\n'
+ } \
+ | sed '
+ $i patch -p1 -i "$srcdir/oneTBB-2021.5.0-no-waitpkg.patch"
+ '
+)"
+
+# -latomic on i486
+if [ "$CARCH" == 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/cmake /cmake -DCMAKE_CXX_STANDARD_LIBRARIES=-latomic /
+ '
+ )"
+fi
+
+# just for now we don't test on i486, we have to do real tests on a
+# real old CPU, in chroots the tests are running, on the real thing
+# they hang (presumably some opcodes are missing or not doing exactly
+# what they do in emulation)..
+# for now it's more important to unstuck the package and build the
+# rest on top
+if [ "$CARCH" == 'i486' ]; then
+ unset check
+fi
diff --git a/extra/tbb/oneTBB-2021.5.0-no-waitpkg.patch b/extra/tbb/oneTBB-2021.5.0-no-waitpkg.patch
new file mode 100644
index 00000000..17d031b4
--- /dev/null
+++ b/extra/tbb/oneTBB-2021.5.0-no-waitpkg.patch
@@ -0,0 +1,12 @@
+diff -rauN oneTBB-2021.5.0/cmake/compilers/GNU.cmake oneTBB-2021.5.0-no-waitpkg-patch/cmake/compilers/GNU.cmake
+--- oneTBB-2021.5.0/cmake/compilers/GNU.cmake 2021-12-17 14:40:54.000000000 +0100
++++ oneTBB-2021.5.0-no-waitpkg-patch/cmake/compilers/GNU.cmake 2022-01-12 16:04:07.448846997 +0100
+@@ -36,7 +36,7 @@
+ endif()
+
+ # Enable Intel(R) Transactional Synchronization Extensions (-mrtm) and WAITPKG instructions support (-mwaitpkg) on relevant processors
+-if (CMAKE_SYSTEM_PROCESSOR MATCHES "(x86|AMD64)")
++if (CMAKE_SYSTEM_PROCESSOR MATCHES "(x86|AMD64|i.86)")
+ set(TBB_COMMON_COMPILE_FLAGS ${TBB_COMMON_COMPILE_FLAGS} -mrtm $<$<AND:$<NOT:$<CXX_COMPILER_ID:Intel>>,$<NOT:$<VERSION_LESS:${CMAKE_CXX_COMPILER_VERSION},11.0>>>:-mwaitpkg>)
+ endif()
+