summaryrefslogtreecommitdiff
path: root/extra/tbb/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/tbb/PKGBUILD')
-rw-r--r--extra/tbb/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/extra/tbb/PKGBUILD b/extra/tbb/PKGBUILD
new file mode 100644
index 00000000..6ddbb31c
--- /dev/null
+++ b/extra/tbb/PKGBUILD
@@ -0,0 +1,34 @@
+# disable waitpkg extensions (error is inline failing in _tpause)
+# (see https://github.com/oneapi-src/oneTBB/issues/370 and
+# https://github.com/oneapi-src/oneTBB/pull/609/commits/542a27fa1cfafaf76772e793549d9f4d288d03a9)
+source+=('oneTBB-2021.5.0-no-waitpkg.patch')
+sha512sums+=('0050970336052909d0572514bb88b8ca12210224bec1245f1c05423f1a8e6e28a5048cc06f969efd81f2de14d342f69641cdfbf9f82ad8e41ca618ae4ce16f16')
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() { cd ${srcdir}/oneTBB-${pkgver}\n}\n'
+ } \
+ | sed '
+ $i patch -p1 -i "$srcdir/oneTBB-2021.5.0-no-waitpkg.patch"
+ '
+)"
+
+# -latomic on i486
+if [ "$CARCH" == 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/cmake /cmake -DCMAKE_CXX_STANDARD_LIBRARIES=-latomic /
+ '
+ )"
+fi
+
+# just for now we don't test on i486, we have to do real tests on a
+# real old CPU, in chroots the tests are running, on the real thing
+# they hang (presumably some opcodes are missing or not doing exactly
+# what they do in emulation)..
+# for now it's more important to unstuck the package and build the
+# rest on top
+if [ "$CARCH" == 'i486' ]; then
+ unset check
+fi