summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
Diffstat (limited to 'core')
-rw-r--r--core/gpgme/PKGBUILD10
-rw-r--r--core/openssl/PKGBUILD1
2 files changed, 11 insertions, 0 deletions
diff --git a/core/gpgme/PKGBUILD b/core/gpgme/PKGBUILD
index f35e9323..121220d1 100644
--- a/core/gpgme/PKGBUILD
+++ b/core/gpgme/PKGBUILD
@@ -1,3 +1,13 @@
+eval "$(
+ declare -f package_python-gpgme package_python2-gpgme qgpgme | \
+ sed '
+ /^\s*{\s*$/ a arch=('"$(
+ printf '%s\n' "${arch[@]}" | \
+ grep -vxF 'i486' | \
+ tr '\n' ' '
+ )"')
+ '
+)"
# i486-specific
if [ "${CARCH}" = "i486" ]; then
# we only build the library
diff --git a/core/openssl/PKGBUILD b/core/openssl/PKGBUILD
index 4446cbc6..1e6e1b30 100644
--- a/core/openssl/PKGBUILD
+++ b/core/openssl/PKGBUILD
@@ -3,6 +3,7 @@ eval "$(
declare -f build | \
sed '
s@linux-x86_64@linux-generic32@
+ s@ enable-ec_nistp_64_gcc_128 @ @
'
)"