summaryrefslogtreecommitdiff
path: root/core/gpgme/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/gpgme/PKGBUILD')
-rw-r--r--core/gpgme/PKGBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/core/gpgme/PKGBUILD b/core/gpgme/PKGBUILD
index f35e9323..121220d1 100644
--- a/core/gpgme/PKGBUILD
+++ b/core/gpgme/PKGBUILD
@@ -1,3 +1,13 @@
+eval "$(
+ declare -f package_python-gpgme package_python2-gpgme qgpgme | \
+ sed '
+ /^\s*{\s*$/ a arch=('"$(
+ printf '%s\n' "${arch[@]}" | \
+ grep -vxF 'i486' | \
+ tr '\n' ' '
+ )"')
+ '
+)"
# i486-specific
if [ "${CARCH}" = "i486" ]; then
# we only build the library