summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
Diffstat (limited to 'core')
-rw-r--r--core/python/PKGBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/core/python/PKGBUILD b/core/python/PKGBUILD
index 1880d300..d95714be 100644
--- a/core/python/PKGBUILD
+++ b/core/python/PKGBUILD
@@ -51,3 +51,13 @@ eval "$(
/-uall/ s/;\?$/ -x test_posix -x test_gdb -x test_socket -x test_cmath -x test_math -x test_turtle \\|\\| true/g
"
)"
+
+# no LTO on 486
+if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/--with-lto/--without-lto/
+ '
+ )"
+fi