summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-03-27 08:44:36 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-03-27 08:44:36 +0200
commit235c850e285c26456fcd3e8e2472bd82869d67c5 (patch)
tree43162efb28d566b61730b1106ad1f7a91686840b /core
parent93ceb150506d3e7bb11b1d2bec850551273025d5 (diff)
downloadpackages-235c850e285c26456fcd3e8e2472bd82869d67c5.tar.xz
core/python: no LTO on i486
Diffstat (limited to 'core')
-rw-r--r--core/python/PKGBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/core/python/PKGBUILD b/core/python/PKGBUILD
index 1880d300..d95714be 100644
--- a/core/python/PKGBUILD
+++ b/core/python/PKGBUILD
@@ -51,3 +51,13 @@ eval "$(
/-uall/ s/;\?$/ -x test_posix -x test_gdb -x test_socket -x test_cmath -x test_math -x test_turtle \\|\\| true/g
"
)"
+
+# no LTO on 486
+if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/--with-lto/--without-lto/
+ '
+ )"
+fi