summaryrefslogtreecommitdiff
path: root/core/libaio
diff options
context:
space:
mode:
Diffstat (limited to 'core/libaio')
-rw-r--r--core/libaio/PKGBUILD26
-rw-r--r--core/libaio/libaio-0.3.111-sizeof-template.patch24
-rw-r--r--core/libaio/libaio-0.3.113-off_t.patch21
3 files changed, 28 insertions, 43 deletions
diff --git a/core/libaio/PKGBUILD b/core/libaio/PKGBUILD
index 1809af7b..0103f113 100644
--- a/core/libaio/PKGBUILD
+++ b/core/libaio/PKGBUILD
@@ -1,23 +1,11 @@
-# see also FS32#30
-# compat-0_1.c:(.text+0xaf): undefined reference to `__stack_chk_fail_local'
+# patch for off_t -> off64_t (test 23)
+source+=('libaio-0.3.113-off_t.patch')
+sha512sums+=('4393b6f1322f9349f3dc00063867a8d80b97ec77978aad60a26424c6749e6800f77f7d854fcaa3d3517fbaba7f0441d694d0afeb43d7a6b5e10b709c65f9fa84')
+b2sums+=('9776de4c42eafd6bcd1042d0a161ac16eb38b4377408d2ad18c4533e6a3d7638fb8cf5cdb9179fa3180a381dc984eefc032f5341d11ce381d7b2914a2dea67bb')
+
eval "$(
- declare -f build | \
+ declare -f prepare | \
sed '
- s/\(CFLAGS=.*\)/#\1/
- s@make$@CFLAGS="-march=${CARCH/_/-} -mtune=generic -O2 -pipe -fno-stack-protector" make@
+ $ i cd $pkgname-$pkgname-$pkgver && patch -Np1 -i "$srcdir/libaio-0.3.113-off_t.patch" \
'
)"
-
-# see also FS#60283
-source+=('libaio-0.3.111-sizeof-template.patch')
-md5sums+=('8c240ea721460fa2d34f9e134b57544d')
-eval "$(
- {
- declare -f prepare || \
- printf 'prepare() {\n}\n'
- } \
- | sed '
- $i cd "${srcdir}/${pkgname}-${pkgver}" \
- patch -Np1 -i ../libaio-0.3.111-sizeof-template.patch
- '
-)"
diff --git a/core/libaio/libaio-0.3.111-sizeof-template.patch b/core/libaio/libaio-0.3.111-sizeof-template.patch
deleted file mode 100644
index 5eee8958..00000000
--- a/core/libaio/libaio-0.3.111-sizeof-template.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -rauN libaio-0.3.111/harness/cases/19.t libaio-0.3.111-sizeof-template-patch/harness/cases/19.t
---- libaio-0.3.111/harness/cases/19.t 2018-03-06 23:24:47.000000000 +0100
-+++ libaio-0.3.111-sizeof-template-patch/harness/cases/19.t 2018-10-14 10:02:19.004873314 +0200
-@@ -41,7 +41,7 @@
- int fd;
- char template[sizeof(TEMPLATE)];
-
-- strncpy(template, TEMPLATE, sizeof(TEMPLATE));
-+ strncpy(template, TEMPLATE, sizeof(template));
- fd = mkostemp(template, O_DIRECT);
- if (fd < 0) {
- perror("mkstemp");
-diff -rauN libaio-0.3.111/harness/cases/21.t libaio-0.3.111-sizeof-template-patch/harness/cases/21.t
---- libaio-0.3.111/harness/cases/21.t 2018-03-06 23:24:47.000000000 +0100
-+++ libaio-0.3.111-sizeof-template-patch/harness/cases/21.t 2018-10-14 10:02:34.901333421 +0200
-@@ -43,7 +43,7 @@
- int fd;
- char temp_file[sizeof(TEMPLATE)];
-
-- strncpy(temp_file, TEMPLATE, sizeof(TEMPLATE));
-+ strncpy(temp_file, TEMPLATE, sizeof(temp_file));
- fd = mkstemp(temp_file);
- if (fd < 0) {
- perror("mkstemp");
diff --git a/core/libaio/libaio-0.3.113-off_t.patch b/core/libaio/libaio-0.3.113-off_t.patch
new file mode 100644
index 00000000..15ae5215
--- /dev/null
+++ b/core/libaio/libaio-0.3.113-off_t.patch
@@ -0,0 +1,21 @@
+diff -rauN libaio-libaio-0.3.113/harness/cases/23.t libaio-libaio-0.3.113-off_t-patch/harness/cases/23.t
+--- libaio-libaio-0.3.113/harness/cases/23.t 2022-04-12 22:49:33.000000000 +0200
++++ libaio-libaio-0.3.113-off_t-patch/harness/cases/23.t 2022-06-02 13:25:40.945786571 +0200
+@@ -72,7 +72,7 @@
+ static void *thrproc2(void *arg)
+ {
+ for (;;) {
+- off_t offset = 0;
++ off64_t offset = 0;
+
+ pthread_barrier_wait(&barrier);
+ if (exiting)
+@@ -92,7 +92,7 @@
+ {
+ for (;;) {
+ char c;
+- off_t offset = 0;
++ off64_t offset = 0;
+
+ pthread_barrier_wait(&barrier);
+ if (exiting)