summaryrefslogtreecommitdiff
path: root/core/libaio/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/libaio/PKGBUILD')
-rw-r--r--core/libaio/PKGBUILD26
1 files changed, 7 insertions, 19 deletions
diff --git a/core/libaio/PKGBUILD b/core/libaio/PKGBUILD
index 1809af7b..0103f113 100644
--- a/core/libaio/PKGBUILD
+++ b/core/libaio/PKGBUILD
@@ -1,23 +1,11 @@
-# see also FS32#30
-# compat-0_1.c:(.text+0xaf): undefined reference to `__stack_chk_fail_local'
+# patch for off_t -> off64_t (test 23)
+source+=('libaio-0.3.113-off_t.patch')
+sha512sums+=('4393b6f1322f9349f3dc00063867a8d80b97ec77978aad60a26424c6749e6800f77f7d854fcaa3d3517fbaba7f0441d694d0afeb43d7a6b5e10b709c65f9fa84')
+b2sums+=('9776de4c42eafd6bcd1042d0a161ac16eb38b4377408d2ad18c4533e6a3d7638fb8cf5cdb9179fa3180a381dc984eefc032f5341d11ce381d7b2914a2dea67bb')
+
eval "$(
- declare -f build | \
+ declare -f prepare | \
sed '
- s/\(CFLAGS=.*\)/#\1/
- s@make$@CFLAGS="-march=${CARCH/_/-} -mtune=generic -O2 -pipe -fno-stack-protector" make@
+ $ i cd $pkgname-$pkgname-$pkgver && patch -Np1 -i "$srcdir/libaio-0.3.113-off_t.patch" \
'
)"
-
-# see also FS#60283
-source+=('libaio-0.3.111-sizeof-template.patch')
-md5sums+=('8c240ea721460fa2d34f9e134b57544d')
-eval "$(
- {
- declare -f prepare || \
- printf 'prepare() {\n}\n'
- } \
- | sed '
- $i cd "${srcdir}/${pkgname}-${pkgver}" \
- patch -Np1 -i ../libaio-0.3.111-sizeof-template.patch
- '
-)"