summaryrefslogtreecommitdiff
path: root/community/libkeccak
diff options
context:
space:
mode:
Diffstat (limited to 'community/libkeccak')
-rw-r--r--community/libkeccak/PKGBUILD19
-rw-r--r--community/libkeccak/libkeccak-1.2.2-no-valgrind.patch15
2 files changed, 34 insertions, 0 deletions
diff --git a/community/libkeccak/PKGBUILD b/community/libkeccak/PKGBUILD
new file mode 100644
index 00000000..5f1e25a0
--- /dev/null
+++ b/community/libkeccak/PKGBUILD
@@ -0,0 +1,19 @@
+# valgrind no longer supports i486 (configuire tests for the binary,
+# no explicit configure option available)
+if [ "$CARCH" = 'i486' ]; then
+ checkdepends=(${checkdepends[@]//valgrind/})
+
+ source+=('libkeccak-1.2.2-no-valgrind.patch')
+ b2sums+=('8c8b23d104e19f1d4431e0f11e6e5995721fe1ed5a8e94ddcd28e8a09e2b11b89e7d7fec896d8b028a77560c4dbcae8f887c0d2fc1ce6f8e0c52e2f1de7a8c09')
+
+ eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $i cd "${srcdir}/${pkgbase}-${pkgver}" \
+ patch -Np1 -i "$srcdir/libkeccak-1.2.2-no-valgrind.patch"
+ '
+ )"
+fi
diff --git a/community/libkeccak/libkeccak-1.2.2-no-valgrind.patch b/community/libkeccak/libkeccak-1.2.2-no-valgrind.patch
new file mode 100644
index 00000000..c8e5d977
--- /dev/null
+++ b/community/libkeccak/libkeccak-1.2.2-no-valgrind.patch
@@ -0,0 +1,15 @@
+diff -rauN libkeccak-1.2.2/Makefile libkeccak-1.2.2-no-valgrind-patch/Makefile
+--- libkeccak-1.2.2/Makefile 2021-07-30 18:59:01.000000000 +0200
++++ libkeccak-1.2.2-no-valgrind-patch/Makefile 2021-08-20 08:33:43.677087692 +0200
+@@ -159,10 +159,7 @@
+ @test $$(sha256sum .testfile | cut -d ' ' -f 1) = \
+ e21d814d21ca269246849cc105faec1a71ac7d1cdb1a86023254f49d51b47231 || \
+ ( echo 'The file .testfile is incorrect, test will fail!' ; false )
+- valgrind --leak-check=full ./test
+- test $$(valgrind ./test 2>&1 >/dev/null | wc -l) = 14
+-# Using valgrind 3.10.0, its output to standard error should consist of 14 lines,
+-# the test itself never prints to standard error.
++ ./test 2>&1 >/dev/null
+
+ benchfile:
+ dd if=/dev/urandom bs=1000 count=50 > $@