summaryrefslogtreecommitdiff
path: root/community/libkeccak/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libkeccak/PKGBUILD')
-rw-r--r--community/libkeccak/PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/community/libkeccak/PKGBUILD b/community/libkeccak/PKGBUILD
new file mode 100644
index 00000000..5f1e25a0
--- /dev/null
+++ b/community/libkeccak/PKGBUILD
@@ -0,0 +1,19 @@
+# valgrind no longer supports i486 (configuire tests for the binary,
+# no explicit configure option available)
+if [ "$CARCH" = 'i486' ]; then
+ checkdepends=(${checkdepends[@]//valgrind/})
+
+ source+=('libkeccak-1.2.2-no-valgrind.patch')
+ b2sums+=('8c8b23d104e19f1d4431e0f11e6e5995721fe1ed5a8e94ddcd28e8a09e2b11b89e7d7fec896d8b028a77560c4dbcae8f887c0d2fc1ce6f8e0c52e2f1de7a8c09')
+
+ eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $i cd "${srcdir}/${pkgbase}-${pkgver}" \
+ patch -Np1 -i "$srcdir/libkeccak-1.2.2-no-valgrind.patch"
+ '
+ )"
+fi