summaryrefslogtreecommitdiff
path: root/community/exa
diff options
context:
space:
mode:
Diffstat (limited to 'community/exa')
-rw-r--r--community/exa/PKGBUILD16
1 files changed, 14 insertions, 2 deletions
diff --git a/community/exa/PKGBUILD b/community/exa/PKGBUILD
index 81065c10..dc7c4354 100644
--- a/community/exa/PKGBUILD
+++ b/community/exa/PKGBUILD
@@ -1,5 +1,7 @@
-# rust currenly broken, is based on LLVM 11
-makedepends+=(llvm11)
+# rust currenly broken, use rust159-bin for now till we can rebuild rust
+# with rist159-bin
+makedepends[@]/cargo/})
+makedepends+=(rust159-bin)
# pandoc is mainly broken currently (FS32#180)
makedepends=(${makedepends[@]//pandoc/})
@@ -16,3 +18,13 @@ eval "$(
/exa_colors.5/d
'
)"
+
+# CARCH pentium4 makes compilation fail
+if [ "$CARCH" = 'pentium4' ]; then
+ eval "$(
+ declare -f prepare | \
+ sed '
+ s/--target "$CARCH-unknown-linux-gnu"/--target "i686-unknown-linux-gnu"/
+ '
+ )"
+fi