summaryrefslogtreecommitdiff
path: root/community/exa
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-04-21 11:46:59 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-04-21 11:46:59 +0200
commit1e719edec4758bac02bdd54e60e3b9fc4a29f673 (patch)
tree97584ef9e8427b7031c42a753ce9740e2453fbb4 /community/exa
parent762ce1b7f7d61282b29708e192d5f5c6fcb3cb35 (diff)
downloadpackages-1e719edec4758bac02bdd54e60e3b9fc4a29f673.tar.xz
community/exa: trying another build with rust159-bin, fix for pentium4 in CARCH
Diffstat (limited to 'community/exa')
-rw-r--r--community/exa/PKGBUILD16
1 files changed, 14 insertions, 2 deletions
diff --git a/community/exa/PKGBUILD b/community/exa/PKGBUILD
index 81065c10..dc7c4354 100644
--- a/community/exa/PKGBUILD
+++ b/community/exa/PKGBUILD
@@ -1,5 +1,7 @@
-# rust currenly broken, is based on LLVM 11
-makedepends+=(llvm11)
+# rust currenly broken, use rust159-bin for now till we can rebuild rust
+# with rist159-bin
+makedepends[@]/cargo/})
+makedepends+=(rust159-bin)
# pandoc is mainly broken currently (FS32#180)
makedepends=(${makedepends[@]//pandoc/})
@@ -16,3 +18,13 @@ eval "$(
/exa_colors.5/d
'
)"
+
+# CARCH pentium4 makes compilation fail
+if [ "$CARCH" = 'pentium4' ]; then
+ eval "$(
+ declare -f prepare | \
+ sed '
+ s/--target "$CARCH-unknown-linux-gnu"/--target "i686-unknown-linux-gnu"/
+ '
+ )"
+fi