summaryrefslogtreecommitdiff
path: root/build-support/python-packaging-bootstrap/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'build-support/python-packaging-bootstrap/PKGBUILD')
-rw-r--r--build-support/python-packaging-bootstrap/PKGBUILD12
1 files changed, 2 insertions, 10 deletions
diff --git a/build-support/python-packaging-bootstrap/PKGBUILD b/build-support/python-packaging-bootstrap/PKGBUILD
index 151a2836..4981528c 100644
--- a/build-support/python-packaging-bootstrap/PKGBUILD
+++ b/build-support/python-packaging-bootstrap/PKGBUILD
@@ -8,7 +8,7 @@
pkgbase=python-packaging-bootstrap
_pkgbase="${pkgbase%-*}"
pkgname=(python-packaging-bootstrap python2-packaging-bootstrap)
-pkgver=20.7
+pkgver=20.4
pkgrel=1
pkgdesc="Core utilities for Python packages - bootstrap version"
arch=('any')
@@ -16,10 +16,8 @@ url="https://github.com/pypa/packaging"
license=('Apache')
makedepends=('python-dephell' 'python-setuptools' 'python2-setuptools' 'python-pyparsing'
'python2-pyparsing')
-checkdepends=('python-pytest' 'python2-pytest' 'python-pretend' 'python2-pretend'
- 'python-coverage' 'python2-coverage')
source=("https://github.com/pypa/packaging/archive/$pkgver/$_pkgbase-$pkgver.tar.gz")
-sha512sums=('4da8f66af066ac92b47664d21af34a02526cd1639cb766927670bec0ac8c7416116834c847678a29862a46faeda7e2f2393744be315cdfbbb8bd55a04ceb942c')
+sha512sums=('507eccfc75682e888ad694e5932f7f699e99a35fdfb55c641cdd1f2162171678fd25c69cc1269a712023d1a8c57c31d2fc6ce46bbe674af66892d29740793013')
build() {
cd packaging-$pkgver
@@ -27,12 +25,6 @@ build() {
python2 setup.py build
}
-check() {
- cd packaging-$pkgver
- python -m pytest
- python2 -m pytest
-}
-
package_python-packaging-bootstrap() {
depends=('python-pyparsing' 'python-six')
provides=("python-packaging=$pkgver")