summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-04-22 09:11:15 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-04-22 09:11:15 +0200
commitaed0feb1e6934db2055725cde1821fbb465a8a99 (patch)
tree09092110afb7040196e7bf4c8fa9fd0303f3335f /extra
parent67a72e636dd09ac6f03af723934d569de50d30fa (diff)
downloadpackages-aed0feb1e6934db2055725cde1821fbb465a8a99.tar.xz
extra/rust: fixed std lib moving
Diffstat (limited to 'extra')
-rw-r--r--extra/rust/PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/extra/rust/PKGBUILD b/extra/rust/PKGBUILD
index cf34e18b..a4adb635 100644
--- a/extra/rust/PKGBUILD
+++ b/extra/rust/PKGBUILD
@@ -19,7 +19,7 @@ eval "$(
eval "$(
declare -f build | \
sed '
- s/-j "$(nproc)"/-j1/
+ s/-j "$(nproc)"/-j8/
'
)"
@@ -38,7 +38,10 @@ fi
eval "$(
declare -f build | \
sed '
+ /mkdir.*usr\/lib32/d
+ /ln.*x86_64.*/d
/mv.*i686-unknown-linux-gnu.*/d
+ /_pick.*dest-i686.*/d
s/x86_64-unknown-linux-musl/i686-unknown-linux-musl/
'
)"