summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-04-11 16:05:54 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-04-11 16:05:54 +0200
commit081a784ed03060e3887425670167f1c2806532df (patch)
treea081c728c3ce961a367ddce72e71c6be813279ea /extra
parent9a11ddf5a29e263f19887e35b26e46699fb9b847 (diff)
downloadpackages-081a784ed03060e3887425670167f1c2806532df.tar.xz
extra/libde265: disable SSE optimizations on i486
Diffstat (limited to 'extra')
-rw-r--r--extra/libde265/PKGBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/extra/libde265/PKGBUILD b/extra/libde265/PKGBUILD
index fa729da7..9ec3baa1 100644
--- a/extra/libde265/PKGBUILD
+++ b/extra/libde265/PKGBUILD
@@ -1,3 +1,13 @@
+# no SSE on i486
+if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s@./configure@./configure --disable-sse@
+ '
+ )"
+fi
+
# break cycle with Qt on i486
if [ "$CARCH" = 'i486' ]; then
makedepends=(${makedepends[@]//qt5-base/})
@@ -8,3 +18,4 @@ if [ "$CARCH" = 'i486' ]; then
'
)"
fi
+