summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--extra/libde265/PKGBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/extra/libde265/PKGBUILD b/extra/libde265/PKGBUILD
index fa729da7..9ec3baa1 100644
--- a/extra/libde265/PKGBUILD
+++ b/extra/libde265/PKGBUILD
@@ -1,3 +1,13 @@
+# no SSE on i486
+if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s@./configure@./configure --disable-sse@
+ '
+ )"
+fi
+
# break cycle with Qt on i486
if [ "$CARCH" = 'i486' ]; then
makedepends=(${makedepends[@]//qt5-base/})
@@ -8,3 +18,4 @@ if [ "$CARCH" = 'i486' ]; then
'
)"
fi
+