summaryrefslogtreecommitdiff
path: root/extra/rust
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-09-09 16:38:56 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2019-09-09 16:38:56 +0200
commit4dc7c8312f982003c6b89423b496798580da2274 (patch)
tree34419c4c9b2cbf7340563218c88abb71242a35da /extra/rust
parent695a49b60aa916fa7c9dbd593f984080688e2368 (diff)
downloadpackages-4dc7c8312f982003c6b89423b496798580da2274.tar.xz
extra/rust: use rust-bin instead of rust from bootstrapping for bootstrapping rust again
Diffstat (limited to 'extra/rust')
-rw-r--r--extra/rust/PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/extra/rust/PKGBUILD b/extra/rust/PKGBUILD
index c0608b3c..1871ee85 100644
--- a/extra/rust/PKGBUILD
+++ b/extra/rust/PKGBUILD
@@ -34,3 +34,7 @@ if [ "${CARCH}" != 'pentium4' ]; then
)"
fi
+# use binary rust-bin instead of rust (till we can bootstrap rust on IA-32)
+# rust is ok on pentium4 but broken on i686 in bootstrap!
+makedepends=(${makedepends[@]//rust/})
+makedepends+=('rust-bin')