summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--extra/rust/PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/extra/rust/PKGBUILD b/extra/rust/PKGBUILD
index c0608b3c..1871ee85 100644
--- a/extra/rust/PKGBUILD
+++ b/extra/rust/PKGBUILD
@@ -34,3 +34,7 @@ if [ "${CARCH}" != 'pentium4' ]; then
)"
fi
+# use binary rust-bin instead of rust (till we can bootstrap rust on IA-32)
+# rust is ok on pentium4 but broken on i686 in bootstrap!
+makedepends=(${makedepends[@]//rust/})
+makedepends+=('rust-bin')