summaryrefslogtreecommitdiff
path: root/extra/rust/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-09-08 16:47:59 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2019-09-08 16:47:59 +0200
commit195a8c09fff2f0520c0871e3d33e8d8895f05c7a (patch)
tree327ab9fc647c600a65feb184e93ab1b4de3e9f18 /extra/rust/PKGBUILD
parent332e24d71e80434afb6023cb98549f0c30295008 (diff)
downloadpackages-195a8c09fff2f0520c0871e3d33e8d8895f05c7a.tar.xz
extra/rust: debuginfo-level-std=1
Diffstat (limited to 'extra/rust/PKGBUILD')
-rw-r--r--extra/rust/PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/extra/rust/PKGBUILD b/extra/rust/PKGBUILD
index 503f34a4..b8c419ce 100644
--- a/extra/rust/PKGBUILD
+++ b/extra/rust/PKGBUILD
@@ -1,7 +1,12 @@
# enable i686-unknown-linux-gnu target
# and replace pentium4 (SSE2) with pentium3 (no SSE2) in the compiler spec file
+#
+# Also trying to reduce memory usage by building with
+# -debuginfo-level-std=1
+# see https://github.com/rust-lang/rust/issues/60294
+
source+=(config.toml.patch)
-sha256sums+=('55d59786b6a24590951688c01910ac331996fc5ea5e20f10d227db24b93b1e74')
+sha256sums+=('a077c28d067f5a0b12fcd4898919773929ff76b788af5ae18bfee7275914076e')
eval "$(
declare -f prepare | \
@@ -28,3 +33,4 @@ if [ "${CARCH}" != 'pentium4' ]; then
'
)"
fi
+