summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-09-08 16:47:59 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2019-09-08 16:47:59 +0200
commit195a8c09fff2f0520c0871e3d33e8d8895f05c7a (patch)
tree327ab9fc647c600a65feb184e93ab1b4de3e9f18
parent332e24d71e80434afb6023cb98549f0c30295008 (diff)
downloadpackages-195a8c09fff2f0520c0871e3d33e8d8895f05c7a.tar.xz
extra/rust: debuginfo-level-std=1
-rw-r--r--extra/rust/PKGBUILD8
-rw-r--r--extra/rust/config.toml.patch16
2 files changed, 20 insertions, 4 deletions
diff --git a/extra/rust/PKGBUILD b/extra/rust/PKGBUILD
index 503f34a4..b8c419ce 100644
--- a/extra/rust/PKGBUILD
+++ b/extra/rust/PKGBUILD
@@ -1,7 +1,12 @@
# enable i686-unknown-linux-gnu target
# and replace pentium4 (SSE2) with pentium3 (no SSE2) in the compiler spec file
+#
+# Also trying to reduce memory usage by building with
+# -debuginfo-level-std=1
+# see https://github.com/rust-lang/rust/issues/60294
+
source+=(config.toml.patch)
-sha256sums+=('55d59786b6a24590951688c01910ac331996fc5ea5e20f10d227db24b93b1e74')
+sha256sums+=('a077c28d067f5a0b12fcd4898919773929ff76b788af5ae18bfee7275914076e')
eval "$(
declare -f prepare | \
@@ -28,3 +33,4 @@ if [ "${CARCH}" != 'pentium4' ]; then
'
)"
fi
+
diff --git a/extra/rust/config.toml.patch b/extra/rust/config.toml.patch
index f479499b..56a3375b 100644
--- a/extra/rust/config.toml.patch
+++ b/extra/rust/config.toml.patch
@@ -1,6 +1,16 @@
---- a/config.toml 2019-01-20 19:03:26.718067950 +0100
-+++ b/config.toml 2019-01-20 19:03:52.614834201 +0100
-@@ -25,3 +25,6 @@
+diff -rauN a/config.toml b/config.toml
+--- a/config.toml 2019-09-08 16:33:31.482763985 +0200
++++ b/config.toml 2019-09-08 16:35:23.644130362 +0200
+@@ -19,7 +19,7 @@
+ # https://github.com/rust-lang/rust/issues/47745
+ codegen-units = 1
+
+-debuginfo-level = 2
++debuginfo-level = 1
+
+ channel = "stable"
+
+@@ -27,3 +27,6 @@
[target.x86_64-unknown-linux-gnu]
llvm-config = "/usr/bin/llvm-config"