summaryrefslogtreecommitdiff
path: root/extra/rust/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-12-09 15:28:20 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2021-12-09 15:28:20 +0100
commit0b65383c196130ae33284e6d70c44e7feb125ded (patch)
tree585a5319493d4cb04dd9c87ef906365f7023ef0c /extra/rust/PKGBUILD
parent622330b3a4158c85615d04f837173d78f024d95d (diff)
downloadpackages-0b65383c196130ae33284e6d70c44e7feb125ded.tar.xz
extra/rust: redone config.toml patch and added llvm12-libs for rebuild
Diffstat (limited to 'extra/rust/PKGBUILD')
-rw-r--r--extra/rust/PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/extra/rust/PKGBUILD b/extra/rust/PKGBUILD
index 7c29aeb9..4750c06c 100644
--- a/extra/rust/PKGBUILD
+++ b/extra/rust/PKGBUILD
@@ -6,7 +6,7 @@
# see https://github.com/rust-lang/rust/issues/60294
source+=(config.toml.patch)
-sha256sums+=('573b9869d71740aa5c7023670926600f5843d6e12480e3c9895caa37a4bc479c')
+sha256sums+=('a8b42b5f47c0eaebafbb2cd1f39d2f944945cbb55e87d4dc21c7bd5b1b8964d8')
eval "$(
declare -f prepare | \
@@ -79,5 +79,5 @@ makedepends=(${makedepends[@]//lib32-gcc-libs/})
#makedepends=(${makedepends[@]//rust/})
#makedepends+=('rust-bin')
-# rust 1.41 is built against llvm11.0, so force that in as a make dependency
-makedepends+=('llvm11-libs')
+# rust 1.56 is built against llvm12.0, so force that in as a make dependency
+makedepends+=('llvm12-libs')