summaryrefslogtreecommitdiff
path: root/extra/rust
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-12-09 15:28:20 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2021-12-09 15:28:20 +0100
commit0b65383c196130ae33284e6d70c44e7feb125ded (patch)
tree585a5319493d4cb04dd9c87ef906365f7023ef0c /extra/rust
parent622330b3a4158c85615d04f837173d78f024d95d (diff)
downloadpackages-0b65383c196130ae33284e6d70c44e7feb125ded.tar.xz
extra/rust: redone config.toml patch and added llvm12-libs for rebuild
Diffstat (limited to 'extra/rust')
-rw-r--r--extra/rust/PKGBUILD6
-rw-r--r--extra/rust/config.toml.patch38
2 files changed, 27 insertions, 17 deletions
diff --git a/extra/rust/PKGBUILD b/extra/rust/PKGBUILD
index 7c29aeb9..4750c06c 100644
--- a/extra/rust/PKGBUILD
+++ b/extra/rust/PKGBUILD
@@ -6,7 +6,7 @@
# see https://github.com/rust-lang/rust/issues/60294
source+=(config.toml.patch)
-sha256sums+=('573b9869d71740aa5c7023670926600f5843d6e12480e3c9895caa37a4bc479c')
+sha256sums+=('a8b42b5f47c0eaebafbb2cd1f39d2f944945cbb55e87d4dc21c7bd5b1b8964d8')
eval "$(
declare -f prepare | \
@@ -79,5 +79,5 @@ makedepends=(${makedepends[@]//lib32-gcc-libs/})
#makedepends=(${makedepends[@]//rust/})
#makedepends+=('rust-bin')
-# rust 1.41 is built against llvm11.0, so force that in as a make dependency
-makedepends+=('llvm11-libs')
+# rust 1.56 is built against llvm12.0, so force that in as a make dependency
+makedepends+=('llvm12-libs')
diff --git a/extra/rust/config.toml.patch b/extra/rust/config.toml.patch
index 3f0bf664..e262d277 100644
--- a/extra/rust/config.toml.patch
+++ b/extra/rust/config.toml.patch
@@ -1,29 +1,39 @@
diff -rauN a/config.toml b/config.toml
---- a/config.toml 2021-07-01 13:11:44.805605461 +0530
-+++ b/config.toml 2021-07-01 13:14:42.562880610 +0530
-@@ -5,7 +5,7 @@
- link-shared = true
-
+--- a/config.toml 2021-12-09 10:47:47.487749605 +0100
++++ b/config.toml 2021-12-09 11:12:50.904278715 +0100
+@@ -6,11 +6,10 @@
+
[build]
--target = ["x86_64-unknown-linux-gnu", "i686-unknown-linux-gnu", "x86_64-unknown-linux-musl"]
-+target = ["i686-unknown-linux-gnu", "i686-unknown-linux-musl"]
+ target = [
+- "x86_64-unknown-linux-gnu",
+ "i686-unknown-linux-gnu",
+- "x86_64-unknown-linux-musl",
++ "i686-unknown-linux-musl",
+ "wasm32-unknown-unknown",
+- "wasm32-wasi",
++ "wasm32-wasi"
+ ]
cargo = "/usr/bin/cargo"
rustc = "/usr/bin/rustc"
- rustfmt = "/usr/bin/rustfmt"
-@@ -24,13 +24,13 @@
- # https://github.com/rust-lang/rust/issues/54872
- codegen-units-std = 1
-
+@@ -28,7 +27,7 @@
+ prefix = "/usr"
+
+ [rust]
-debuginfo-level-std = 2
+debuginfo-level-std = 0
channel = "stable"
+ description = "Arch Linux $pkgbase $epoch:$pkgver-$pkgrel"
rpath = false
-
+@@ -45,10 +44,10 @@
+ [dist]
+ compression-formats = ["gz"]
+
-[target.x86_64-unknown-linux-gnu]
+[target.i686-unknown-linux-gnu]
llvm-config = "/usr/bin/llvm-config"
-
+
-[target.x86_64-unknown-linux-musl]
+[target.i686-unknown-linux-musl]
sanitizers = false
musl-root = "/usr/lib/musl"
+