summaryrefslogtreecommitdiff
path: root/extra/lightdm
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-05-29 15:26:28 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-05-29 15:26:28 +0200
commit07e5853650a96bf7c258cb12a83be6ec745ffa37 (patch)
treebbd28331399fc62824bd0d1059c83bec8af431d6 /extra/lightdm
parent434b42dac51e916abbba5a4ecfdca700e5f470cc (diff)
downloadpackages-07e5853650a96bf7c258cb12a83be6ec745ffa37.tar.xz
extra/lightdm: moved and merged from community/lightdm
Diffstat (limited to 'extra/lightdm')
-rw-r--r--extra/lightdm/PKGBUILD14
1 files changed, 14 insertions, 0 deletions
diff --git a/extra/lightdm/PKGBUILD b/extra/lightdm/PKGBUILD
index 415ddd35..9288f4d3 100644
--- a/extra/lightdm/PKGBUILD
+++ b/extra/lightdm/PKGBUILD
@@ -1,3 +1,17 @@
+# use polkit-duktape instead of polkit on i486
+if [ "$CARCH" = 'i486' ]; then
+ makedepends=(${makedepends[@]//polkit/})
+ makedepends+=(polkit-duktape)
+ if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f package_lightdm | \
+ sed '
+ /depends/s/polkit/polkit-duktape/
+ '
+ )"
+ fi
+fi
+
eval "$(
declare -f package_lightdm | \
sed '