summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-05-29 15:26:28 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-05-29 15:26:28 +0200
commit07e5853650a96bf7c258cb12a83be6ec745ffa37 (patch)
treebbd28331399fc62824bd0d1059c83bec8af431d6
parent434b42dac51e916abbba5a4ecfdca700e5f470cc (diff)
downloadpackages-07e5853650a96bf7c258cb12a83be6ec745ffa37.tar.xz
extra/lightdm: moved and merged from community/lightdm
-rw-r--r--community/lightdm/PKGBUILD13
-rw-r--r--extra/lightdm/PKGBUILD14
2 files changed, 14 insertions, 13 deletions
diff --git a/community/lightdm/PKGBUILD b/community/lightdm/PKGBUILD
deleted file mode 100644
index 774930a4..00000000
--- a/community/lightdm/PKGBUILD
+++ /dev/null
@@ -1,13 +0,0 @@
-# use polkit-duktape instead of polkit on i486
-if [ "$CARCH" = 'i486' ]; then
- makedepends=(${makedepends[@]//polkit/})
- makedepends+=(polkit-duktape)
- if [ "$CARCH" = 'i486' ]; then
- eval "$(
- declare -f package_lightdm | \
- sed '
- /depends/s/polkit/polkit-duktape/
- '
- )"
- fi
-fi
diff --git a/extra/lightdm/PKGBUILD b/extra/lightdm/PKGBUILD
index 415ddd35..9288f4d3 100644
--- a/extra/lightdm/PKGBUILD
+++ b/extra/lightdm/PKGBUILD
@@ -1,3 +1,17 @@
+# use polkit-duktape instead of polkit on i486
+if [ "$CARCH" = 'i486' ]; then
+ makedepends=(${makedepends[@]//polkit/})
+ makedepends+=(polkit-duktape)
+ if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f package_lightdm | \
+ sed '
+ /depends/s/polkit/polkit-duktape/
+ '
+ )"
+ fi
+fi
+
eval "$(
declare -f package_lightdm | \
sed '