summaryrefslogtreecommitdiff
path: root/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2020-08-29 06:23:34 +0200
committerErich Eckner <git@eckner.net>2020-08-29 06:23:34 +0200
commit4963529ebfa83f494ef0d9e9a8e5905d19967c2e (patch)
tree099b1254f9f17f1661dde6b6819a33b377e73f62 /extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
parentf52a27d83ed2f76a8d5e7bf7ee71be7cc8c2756c (diff)
downloadpackages-4963529ebfa83f494ef0d9e9a8e5905d19967c2e.tar.xz
extra/firefox: update rust-static-disable-network-test-on-static-libraries.patch - thanks, bill-auger!
Diffstat (limited to 'extra/firefox/rust-static-disable-network-test-on-static-libraries.patch')
-rw-r--r--extra/firefox/rust-static-disable-network-test-on-static-libraries.patch32
1 files changed, 19 insertions, 13 deletions
diff --git a/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch b/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
index 7bcbde2a..95c2df7e 100644
--- a/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
+++ b/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
@@ -1,27 +1,33 @@
---- firefox-79.0/config/makefiles/rust.mk 2020-07-21 00:49:36.000000000 +0200
-+++ firefox-79.0-rust-static-disable-network-test-on-static-libraries-patch/config/makefiles/rust.mk 2020-08-02 13:56:36.118444982 +0200
-@@ -299,15 +299,15 @@
+diff --git a/config/makefiles/rust.mk b/config/makefiles/rust.mk
+index 58606db50f..9c4d5b9279 100644
+--- a/config/makefiles/rust.mk
++++ b/config/makefiles/rust.mk
+@@ -305,17 +305,17 @@ $(RUST_LIBRARY_FILE): force-cargo-library-build
# the chance of proxy bypasses originating from rust code.
- # The check only works when rust code is built with -Clto.
+ # The check only works when rust code is built with -Clto but without MOZ_LTO_RUST.
# Sanitizers and sancov also fail because compiler-rt hooks network functions.
-ifndef MOZ_PROFILE_GENERATE
-ifeq ($(OS_ARCH), Linux)
-ifeq (,$(rustflags_sancov)$(MOZ_ASAN)$(MOZ_TSAN)$(MOZ_UBSAN))
+-ifndef MOZ_LTO_RUST
-ifneq (,$(filter -Clto,$(cargo_rustc_flags)))
- $(call py_action,check_binary,--target --networking $@)
-endif
-endif
-endif
-endif
-+#ifndef MOZ_PROFILE_GENERATE
-+#ifeq ($(OS_ARCH), Linux)
-+#ifeq (,$(rustflags_sancov)$(MOZ_ASAN)$(MOZ_TSAN)$(MOZ_UBSAN))
-+#ifneq (,$(filter -Clto,$(cargo_rustc_flags)))
-+# $(call py_action,check_binary,--target --networking $@)
-+#endif
-+#endif
-+#endif
-+#endif
+-endif
++# ifndef MOZ_PROFILE_GENERATE
++# ifeq ($(OS_ARCH), Linux)
++# ifeq (,$(rustflags_sancov)$(MOZ_ASAN)$(MOZ_TSAN)$(MOZ_UBSAN))
++# ifndef MOZ_LTO_RUST
++# ifneq (,$(filter -Clto,$(cargo_rustc_flags)))
++# $(call py_action,check_binary,--target --networking $@)
++# endif
++# endif
++# endif
++# endif
++# endif
force-cargo-library-check:
$(call CARGO_CHECK) --lib $(cargo_target_flag) $(rust_features_flag)