summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2020-08-29 06:23:34 +0200
committerErich Eckner <git@eckner.net>2020-08-29 06:23:34 +0200
commit4963529ebfa83f494ef0d9e9a8e5905d19967c2e (patch)
tree099b1254f9f17f1661dde6b6819a33b377e73f62
parentf52a27d83ed2f76a8d5e7bf7ee71be7cc8c2756c (diff)
downloadpackages-4963529ebfa83f494ef0d9e9a8e5905d19967c2e.tar.xz
extra/firefox: update rust-static-disable-network-test-on-static-libraries.patch - thanks, bill-auger!
-rw-r--r--extra/firefox/PKGBUILD2
-rw-r--r--extra/firefox/rust-static-disable-network-test-on-static-libraries.patch32
2 files changed, 20 insertions, 14 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index cd32ea26..6adaa234 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -125,7 +125,7 @@ eval "$(
# test failure in rust code (complaining about network functions) when PGO is used,
# see https://bugzilla.mozilla.org/show_bug.cgi?id=1565757
source+=('rust-static-disable-network-test-on-static-libraries.patch')
-sha256sums+=('cff239cbeca6fb6171ed4849b6b42173ce6b4fd2f671e1d5dedd1d81795f3da8')
+sha256sums+=('e661665ee00ecec66c33e115b0af3474452022f0d8ceda634a6315dc8cb99014')
eval "$(
declare -f prepare | \
sed '
diff --git a/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch b/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
index 7bcbde2a..95c2df7e 100644
--- a/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
+++ b/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
@@ -1,27 +1,33 @@
---- firefox-79.0/config/makefiles/rust.mk 2020-07-21 00:49:36.000000000 +0200
-+++ firefox-79.0-rust-static-disable-network-test-on-static-libraries-patch/config/makefiles/rust.mk 2020-08-02 13:56:36.118444982 +0200
-@@ -299,15 +299,15 @@
+diff --git a/config/makefiles/rust.mk b/config/makefiles/rust.mk
+index 58606db50f..9c4d5b9279 100644
+--- a/config/makefiles/rust.mk
++++ b/config/makefiles/rust.mk
+@@ -305,17 +305,17 @@ $(RUST_LIBRARY_FILE): force-cargo-library-build
# the chance of proxy bypasses originating from rust code.
- # The check only works when rust code is built with -Clto.
+ # The check only works when rust code is built with -Clto but without MOZ_LTO_RUST.
# Sanitizers and sancov also fail because compiler-rt hooks network functions.
-ifndef MOZ_PROFILE_GENERATE
-ifeq ($(OS_ARCH), Linux)
-ifeq (,$(rustflags_sancov)$(MOZ_ASAN)$(MOZ_TSAN)$(MOZ_UBSAN))
+-ifndef MOZ_LTO_RUST
-ifneq (,$(filter -Clto,$(cargo_rustc_flags)))
- $(call py_action,check_binary,--target --networking $@)
-endif
-endif
-endif
-endif
-+#ifndef MOZ_PROFILE_GENERATE
-+#ifeq ($(OS_ARCH), Linux)
-+#ifeq (,$(rustflags_sancov)$(MOZ_ASAN)$(MOZ_TSAN)$(MOZ_UBSAN))
-+#ifneq (,$(filter -Clto,$(cargo_rustc_flags)))
-+# $(call py_action,check_binary,--target --networking $@)
-+#endif
-+#endif
-+#endif
-+#endif
+-endif
++# ifndef MOZ_PROFILE_GENERATE
++# ifeq ($(OS_ARCH), Linux)
++# ifeq (,$(rustflags_sancov)$(MOZ_ASAN)$(MOZ_TSAN)$(MOZ_UBSAN))
++# ifndef MOZ_LTO_RUST
++# ifneq (,$(filter -Clto,$(cargo_rustc_flags)))
++# $(call py_action,check_binary,--target --networking $@)
++# endif
++# endif
++# endif
++# endif
++# endif
force-cargo-library-check:
$(call CARGO_CHECK) --lib $(cargo_target_flag) $(rust_features_flag)