summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-03-24 11:24:38 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2022-03-24 11:24:38 +0100
commitc7738474d36492e329d79f3c4977a37c18979ae4 (patch)
treef244d3ed82b6b732bc2ae6971d01c3e6842fd2c0 /core
parentd93d8d2dbb125956b0c076bb2388c45b002dfaee (diff)
downloadpackages-c7738474d36492e329d79f3c4977a37c18979ae4.tar.xz
core/systemd: disabled LTO in EFI boot on i486 (fails to find efi_main entrypoint)
Diffstat (limited to 'core')
-rw-r--r--core/systemd/PKGBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/core/systemd/PKGBUILD b/core/systemd/PKGBUILD
index 0238f208..223a7cb8 100644
--- a/core/systemd/PKGBUILD
+++ b/core/systemd/PKGBUILD
@@ -5,3 +5,14 @@ eval "$(
s/\(meson test -C build\)/\1 || true/
'
)"
+
+# disabling LTO on i486 in EFI, fails with undefined entry point efi_main
+if [ "${CARCH}" = "i486" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ /local _meson_options.*/ a \
+ _meson_options+=(-Db_lto=false)
+ '
+ )"
+fi