summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--core/systemd/PKGBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/core/systemd/PKGBUILD b/core/systemd/PKGBUILD
index 0238f208..223a7cb8 100644
--- a/core/systemd/PKGBUILD
+++ b/core/systemd/PKGBUILD
@@ -5,3 +5,14 @@ eval "$(
s/\(meson test -C build\)/\1 || true/
'
)"
+
+# disabling LTO on i486 in EFI, fails with undefined entry point efi_main
+if [ "${CARCH}" = "i486" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ /local _meson_options.*/ a \
+ _meson_options+=(-Db_lto=false)
+ '
+ )"
+fi