summaryrefslogtreecommitdiff
path: root/core/pcre2
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2018-09-14 15:16:13 +0200
committerErich Eckner <git@eckner.net>2018-09-14 15:16:13 +0200
commit5e06535e22788a5f119f908621412a8a86d8a692 (patch)
tree257b6673ea725af4eb87d8491c1fa5bfc82b90bf /core/pcre2
parentb2b8023c637c8579ce900c7113c4783ae5dea1fd (diff)
downloadpackages-5e06535e22788a5f119f908621412a8a86d8a692.tar.xz
copy over i486 changes for [core]
Diffstat (limited to 'core/pcre2')
-rw-r--r--core/pcre2/PKGBUILD13
1 files changed, 13 insertions, 0 deletions
diff --git a/core/pcre2/PKGBUILD b/core/pcre2/PKGBUILD
new file mode 100644
index 00000000..da90f860
--- /dev/null
+++ b/core/pcre2/PKGBUILD
@@ -0,0 +1,13 @@
+# 486-specific: we have no Vala or Java at the moment
+if [ "${CARCH}" = "i486" ]; then
+ # pcre2 configure, overload CFLAGS and CXXFLAGS to avoid optimization
+ # using MMX registers (default in gcc)
+ # disable JIT, contains hard coded XMM registers
+ eval "$(
+ declare -f build | \
+ sed '
+ s@./configure@CFLAGS="-march=i486 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt" CXXFLAGS="-march=i486 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt" ./configure@
+ s/--enable-jit/--disable-jit/
+ '
+ )"
+fi