summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2018-09-14 15:16:13 +0200
committerErich Eckner <git@eckner.net>2018-09-14 15:16:13 +0200
commit5e06535e22788a5f119f908621412a8a86d8a692 (patch)
tree257b6673ea725af4eb87d8491c1fa5bfc82b90bf
parentb2b8023c637c8579ce900c7113c4783ae5dea1fd (diff)
downloadpackages-5e06535e22788a5f119f908621412a8a86d8a692.tar.xz
copy over i486 changes for [core]
-rw-r--r--core/openssl/PKGBUILD11
-rw-r--r--core/pacman/PKGBUILD12
-rw-r--r--core/pcre2/PKGBUILD13
3 files changed, 36 insertions, 0 deletions
diff --git a/core/openssl/PKGBUILD b/core/openssl/PKGBUILD
new file mode 100644
index 00000000..e3e0d088
--- /dev/null
+++ b/core/openssl/PKGBUILD
@@ -0,0 +1,11 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s@no-ssl3-method@no-ssl3-method no-ssl2 no-ssl3@
+ s@'i686'@'i486'@
+ s@'linux-elf'@'linux-generic32'@
+ '
+ )"
+fi
diff --git a/core/pacman/PKGBUILD b/core/pacman/PKGBUILD
index ed748bb4..86372fc6 100644
--- a/core/pacman/PKGBUILD
+++ b/core/pacman/PKGBUILD
@@ -11,3 +11,15 @@ for ((i=0; i<${#sha256sums[@]}; i++)); do
sha256sums[${i}]='d1c3e5f9b7259e401ab121aff335531452d23dc67d9e6c2f464771d25f11058a'
fi
done
+
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # patch architecture where needed
+ eval "$(
+ declare -f package | \
+ sed '
+ /install.*makepkg.conf/ a \
+ sed -i "s@i686@i486@g" "$pkgdir/etc/makepkg.conf"
+ '
+ )"
+fi
diff --git a/core/pcre2/PKGBUILD b/core/pcre2/PKGBUILD
new file mode 100644
index 00000000..da90f860
--- /dev/null
+++ b/core/pcre2/PKGBUILD
@@ -0,0 +1,13 @@
+# 486-specific: we have no Vala or Java at the moment
+if [ "${CARCH}" = "i486" ]; then
+ # pcre2 configure, overload CFLAGS and CXXFLAGS to avoid optimization
+ # using MMX registers (default in gcc)
+ # disable JIT, contains hard coded XMM registers
+ eval "$(
+ declare -f build | \
+ sed '
+ s@./configure@CFLAGS="-march=i486 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt" CXXFLAGS="-march=i486 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt" ./configure@
+ s/--enable-jit/--disable-jit/
+ '
+ )"
+fi