summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-01-21 10:10:08 +0100
committerErich Eckner <git@eckner.net>2019-01-21 10:10:08 +0100
commit826946fc5850f99f21151d575e3d01c2180c8881 (patch)
tree57952daf8f036922a378ddf251fba244283cf15e /community
parentb1ef18278ba295fcddd30751d8294e76e638724e (diff)
parent500ec8d4e6dc3f4ee834c1dd9f4dc5bc43e37196 (diff)
downloadpackages-826946fc5850f99f21151d575e3d01c2180c8881.tar.xz
Merge branch 'master' into i486
Diffstat (limited to 'community')
-rw-r--r--community/exa/PKGBUILD9
-rw-r--r--community/exa/exa-ascii-deprecated.patch12
-rw-r--r--community/openscenegraph34/PKGBUILD6
3 files changed, 27 insertions, 0 deletions
diff --git a/community/exa/PKGBUILD b/community/exa/PKGBUILD
new file mode 100644
index 00000000..1de368f8
--- /dev/null
+++ b/community/exa/PKGBUILD
@@ -0,0 +1,9 @@
+# fixed in git upstream
+
+source+=('exa-ascii-deprecated.patch')
+md5sums+=('ce36630a183f5d5be9f1a334bdf8a7cc')
+
+prepare() {
+ cd "$pkgname"
+ patch -Np1 -i ../exa-ascii-deprecated.patch
+}
diff --git a/community/exa/exa-ascii-deprecated.patch b/community/exa/exa-ascii-deprecated.patch
new file mode 100644
index 00000000..e4cddd6a
--- /dev/null
+++ b/community/exa/exa-ascii-deprecated.patch
@@ -0,0 +1,12 @@
+diff -rauN exa/src/fs/file.rs exa-ascii-deprecated-patch/src/fs/file.rs
+--- exa/src/fs/file.rs 2018-12-09 12:48:21.137587385 +0100
++++ exa-ascii-deprecated-patch/src/fs/file.rs 2018-12-09 12:59:07.048431583 +0100
+@@ -95,8 +95,6 @@
+ /// against a pre-compiled list of extensions which are known to only exist
+ /// within ASCII, so it’s alright.
+ fn ext(path: &Path) -> Option<String> {
+- use std::ascii::AsciiExt;
+-
+ let name = match path.file_name() {
+ Some(f) => f.to_string_lossy().to_string(),
+ None => return None,
diff --git a/community/openscenegraph34/PKGBUILD b/community/openscenegraph34/PKGBUILD
new file mode 100644
index 00000000..78dcdca7
--- /dev/null
+++ b/community/openscenegraph34/PKGBUILD
@@ -0,0 +1,6 @@
+eval "$(
+ declare -f package | \
+ sed '
+ s@mv "${pkgdir}/usr/lib64" "${pkgdir}/usr/lib"@#\0@
+ '
+)"