summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-01-21 10:09:55 +0100
committerErich Eckner <git@eckner.net>2019-01-21 10:09:55 +0100
commitb1ef18278ba295fcddd30751d8294e76e638724e (patch)
treec04e42280fe27b7c73195b0cba36b73faae44400 /community
parent70a7c30b8196a4398cf755b93507516d0f83be56 (diff)
parent665c195f3812e8a410095ac2ffa5a692116870e2 (diff)
downloadpackages-b1ef18278ba295fcddd30751d8294e76e638724e.tar.xz
Merge branch 'master' into i486
Diffstat (limited to 'community')
-rw-r--r--community/dart/PKGBUILD2
-rw-r--r--community/freebasic/PKGBUILD9
-rw-r--r--community/gap/PKGBUILD6
-rw-r--r--community/grim/PKGBUILD7
-rw-r--r--community/grim/bced8c88165bd15cf97d3b55a9241b0a6ee1fe3c.patch80
-rw-r--r--community/hq/PKGBUILD7
-rw-r--r--community/hq/hq-ia32.patch12
-rw-r--r--community/teamspeak3-server/PKGBUILD2
8 files changed, 37 insertions, 88 deletions
diff --git a/community/dart/PKGBUILD b/community/dart/PKGBUILD
index 88e30efe..452a714f 100644
--- a/community/dart/PKGBUILD
+++ b/community/dart/PKGBUILD
@@ -1,2 +1,2 @@
source=("$pkgname-$pkgver-32.zip::http://storage.googleapis.com/dart-archive/channels/stable/release/latest/sdk/dartsdk-linux-ia32-release.zip")
-sha512sums=('7e2ba689f4e222d545720c34f0581df5b4e64f39eaf71e3af294ce20869652d71981ae5e95153fe87e049e1fbf8375870209b3b6eae2da8688b75a80f255033b')
+sha512sums=('7723a38f9ed4b9f7d0d2b2098bfacc2eaeb2fa1d75591efd82f8d2e211625c37e10839251f89cd342008cc912e3921ef473a63e7ee74b6cd1853bd1999759fd1')
diff --git a/community/freebasic/PKGBUILD b/community/freebasic/PKGBUILD
new file mode 100644
index 00000000..953b0e82
--- /dev/null
+++ b/community/freebasic/PKGBUILD
@@ -0,0 +1,9 @@
+source_i686=("http://downloads.sourceforge.net/fbc/FreeBASIC-${pkgver}-linux-x86.tar.xz")
+md5sums_i686=('50aec8fcfa577dc7a76cffc6dfe50476')
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ /CARCH/ a [[ "$CARCH" = "i686" ]] && _arch=x86
+ '
+)"
diff --git a/community/gap/PKGBUILD b/community/gap/PKGBUILD
new file mode 100644
index 00000000..b9a33e53
--- /dev/null
+++ b/community/gap/PKGBUILD
@@ -0,0 +1,6 @@
+eval "$(
+ declare -f package_gap-packages | \
+ sed '
+ /chrpath/ s/x86_64-pc-linux-gnu-default64/i686-pc-linux-gnu-default32/
+ '
+)"
diff --git a/community/grim/PKGBUILD b/community/grim/PKGBUILD
deleted file mode 100644
index 4c7f6cf1..00000000
--- a/community/grim/PKGBUILD
+++ /dev/null
@@ -1,7 +0,0 @@
-# temporary fix for type mismatch
-source+=('bced8c88165bd15cf97d3b55a9241b0a6ee1fe3c.patch')
-sha256sums+=('9614a426ac697cacbb7e08f6d5a12466071052d7ae14ef31a05e51d50f510de1')
-prepare() {
- cd "$pkgname"
- patch -p1 -i '../bced8c88165bd15cf97d3b55a9241b0a6ee1fe3c.patch'
-}
diff --git a/community/grim/bced8c88165bd15cf97d3b55a9241b0a6ee1fe3c.patch b/community/grim/bced8c88165bd15cf97d3b55a9241b0a6ee1fe3c.patch
deleted file mode 100644
index 48afa84f..00000000
--- a/community/grim/bced8c88165bd15cf97d3b55a9241b0a6ee1fe3c.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-From aa679f0501a30fb5a452d35f7ef9d7ed2c3fa2f9 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Jan=20Pokorn=C3=BD?= <jpokorny@fedoraproject.org>
-Date: Sat, 3 Nov 2018 15:16:08 +0100
-Subject: [PATCH] Fix i686 build -Werror=incompatible-pointer-types complaint
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-This was caused with jpeg_mem_dest expecting pointer to unsigned long
-and being fed with pointer to size_t, which may amount to different
-data-width types. There's also a simple overflow check for such
-cases now.
-
-Signed-off-by: Jan Pokorný <jpokorny@fedoraproject.org>
----
- cairo_jpg.c | 17 +++++++++--------
- include/cairo_jpg.h | 2 +-
- 2 files changed, 10 insertions(+), 9 deletions(-)
-
-diff --git a/cairo_jpg.c b/cairo_jpg.c
-index e905e4e..3a37a37 100644
---- a/cairo_jpg.c
-+++ b/cairo_jpg.c
-@@ -7,7 +7,9 @@
- #include <stdlib.h>
- #include <sys/types.h>
- #include <sys/stat.h>
-+#include <assert.h>
- #include <fcntl.h>
-+#include <limits.h>
- #include <unistd.h>
- #include <cairo.h>
- #include <jpeglib.h>
-@@ -15,7 +17,7 @@
- #include "cairo_jpg.h"
-
- cairo_status_t cairo_surface_write_to_jpeg_mem(cairo_surface_t *sfc,
-- unsigned char **data, size_t *len, int quality) {
-+ unsigned char **data, unsigned long *len, int quality) {
- struct jpeg_compress_struct cinfo;
- struct jpeg_error_mgr jerr;
- JSAMPROW row_pointer[1];
-@@ -91,18 +93,17 @@ cairo_status_t cairo_surface_write_to_jpeg_stream(cairo_surface_t *sfc,
- cairo_write_func_t write_func, void *closure, int quality) {
- cairo_status_t e;
- unsigned char *data = NULL;
-- size_t len = 0;
-+ unsigned long len = 0;
-
- e = cairo_surface_write_to_jpeg_mem(sfc, &data, &len, quality);
-- if (e != CAIRO_STATUS_SUCCESS) {
-- return e;
-+ if (e == CAIRO_STATUS_SUCCESS) {
-+ assert(sizeof(unsigned long) <= sizeof(size_t)
-+ || !(len >> (sizeof(size_t) * CHAR_BIT)));
-+ e = write_func(closure, data, len);
-+ free(data);
- }
-
-- e = write_func(closure, data, len);
--
-- free(data);
- return e;
--
- }
-
- cairo_status_t cairo_surface_write_to_jpeg(cairo_surface_t *sfc,
-diff --git a/include/cairo_jpg.h b/include/cairo_jpg.h
-index a2d0328..7e09e55 100644
---- a/include/cairo_jpg.h
-+++ b/include/cairo_jpg.h
-@@ -3,7 +3,7 @@
-
- #include <cairo.h>
-
--cairo_status_t cairo_surface_write_to_jpeg_mem(cairo_surface_t *sfc, unsigned char **data, size_t *len, int quality);
-+cairo_status_t cairo_surface_write_to_jpeg_mem(cairo_surface_t *sfc, unsigned char **data, unsigned long *len, int quality);
- cairo_status_t cairo_surface_write_to_jpeg_stream(cairo_surface_t *sfc, cairo_write_func_t write_func, void *closure, int quality);
- cairo_status_t cairo_surface_write_to_jpeg(cairo_surface_t *sfc, const char *filename, int quality);
-
diff --git a/community/hq/PKGBUILD b/community/hq/PKGBUILD
new file mode 100644
index 00000000..4e22d247
--- /dev/null
+++ b/community/hq/PKGBUILD
@@ -0,0 +1,7 @@
+# see upstream https://github.com/coderobe/hq/pull/1
+source+=('hq-ia32.patch')
+md5sums+=('3cecc7f3b1bbe96f6c3a1609730ba574')
+prepare() {
+ cd "${pkgname}"
+ patch -Np1 -i ../hq-ia32.patch
+}
diff --git a/community/hq/hq-ia32.patch b/community/hq/hq-ia32.patch
new file mode 100644
index 00000000..07a924e0
--- /dev/null
+++ b/community/hq/hq-ia32.patch
@@ -0,0 +1,12 @@
+diff -rauN hq/main.cpp hq-ia32-patch/main.cpp
+--- hq/main.cpp 2018-11-25 17:00:49.731669567 +0100
++++ hq-ia32-patch/main.cpp 2018-11-25 17:01:32.498826389 +0100
+@@ -51,7 +51,7 @@
+ static const string afmt_s = "\033[";
+ static const string afmt_e = "m";
+ static const vector<char> collapsible = {' ', '\t', '\n', '\r'};
+-static const vector<unsigned long> breaking = {
++static const vector<myhtml_tag_id_t> breaking = {
+ MyHTML_TAG_BR,
+ MyHTML_TAG_P
+ };
diff --git a/community/teamspeak3-server/PKGBUILD b/community/teamspeak3-server/PKGBUILD
new file mode 100644
index 00000000..3d518c16
--- /dev/null
+++ b/community/teamspeak3-server/PKGBUILD
@@ -0,0 +1,2 @@
+sha256sums_i686=('f5ff4d313865ca8ab4a9c63f447f584a9363a313624950f683ec4d6f59d55059')
+