summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-01-21 10:10:30 +0100
committerErich Eckner <git@eckner.net>2019-01-21 10:10:30 +0100
commit44997e9d4fe44e6c7c4a55556d888ae1d9a94fc5 (patch)
treed567725073108ad43ad984ac3e8bbdafd59de0e4 /community
parent110c12613a8ad230c4afb0e699a1e835f1dab6d0 (diff)
parentbb161a0de693802cdcec8d1b06c90b7450b39932 (diff)
downloadpackages-44997e9d4fe44e6c7c4a55556d888ae1d9a94fc5.tar.xz
Merge branch 'master' into i486
Diffstat (limited to 'community')
-rw-r--r--community/dtc/PKGBUILD3
-rw-r--r--community/electron/PKGBUILD2
-rw-r--r--community/electron2/PKGBUILD2
-rw-r--r--community/netcdf-openmpi/PKGBUILD11
-rw-r--r--community/netcdf/PKGBUILD7
-rw-r--r--community/openipmi/PKGBUILD2
6 files changed, 25 insertions, 2 deletions
diff --git a/community/dtc/PKGBUILD b/community/dtc/PKGBUILD
new file mode 100644
index 00000000..d97cb9a7
--- /dev/null
+++ b/community/dtc/PKGBUILD
@@ -0,0 +1,3 @@
+# revert commit 1799ef5ac2fba01a19e89b5bef23315a7570624b
+source+=('fix32bit.patch::https://github.com/dgibson/dtc/commit/f8872e29ce06d78d3db71b3ab26a7465fc8a9586.patch')
+sha256sums+=('e92bfc787b65e2610528d5c499835c083c1672455fc7998d202b7c986d5c5f1d')
diff --git a/community/electron/PKGBUILD b/community/electron/PKGBUILD
index 395d76f9..3446fe23 100644
--- a/community/electron/PKGBUILD
+++ b/community/electron/PKGBUILD
@@ -10,7 +10,7 @@ eval "$(
'
declare -f build | \
sed '
- \,^\s*script/bootstrap.py , s/py/py --target_arch=ia32/
+ s,^\s*script/bootstrap.py ,\0--target_arch=ia32 ,
s/-t x64/-t ia32/g
'
)"
diff --git a/community/electron2/PKGBUILD b/community/electron2/PKGBUILD
index 4f1a6f90..3446fe23 100644
--- a/community/electron2/PKGBUILD
+++ b/community/electron2/PKGBUILD
@@ -10,7 +10,7 @@ eval "$(
'
declare -f build | \
sed '
- s,/bootstrap.py ,\0--target_arch=ia32 ,
+ s,^\s*script/bootstrap.py ,\0--target_arch=ia32 ,
s/-t x64/-t ia32/g
'
)"
diff --git a/community/netcdf-openmpi/PKGBUILD b/community/netcdf-openmpi/PKGBUILD
new file mode 100644
index 00000000..e18dbf41
--- /dev/null
+++ b/community/netcdf-openmpi/PKGBUILD
@@ -0,0 +1,11 @@
+# breaking a cycle with pnetcdf-openmpi
+depends=(${depends[@]//"pnetcdf-${_mpi}"/})
+
+# "Unable to support CDF5 feature because size_t is less than 8 bytes"
+eval "$(
+ declare -f build | \
+ sed '
+ s/-DENABLE_CDF5=ON/-DENABLE_CDF5=OFF/g
+ s/-DENABLE_PNETCDF=ON/-DENABLE_PNETCDF=OFF/g
+ '
+)"
diff --git a/community/netcdf/PKGBUILD b/community/netcdf/PKGBUILD
new file mode 100644
index 00000000..69f8f47a
--- /dev/null
+++ b/community/netcdf/PKGBUILD
@@ -0,0 +1,7 @@
+# "Unable to support CDF5 feature because size_t is less than 8 bytes"
+eval "$(
+ declare -f build | \
+ sed '
+ s/-DENABLE_CDF5=ON/-DENABLE_CDF5=OFF/g
+ '
+)"
diff --git a/community/openipmi/PKGBUILD b/community/openipmi/PKGBUILD
new file mode 100644
index 00000000..46c10e69
--- /dev/null
+++ b/community/openipmi/PKGBUILD
@@ -0,0 +1,2 @@
+# see FS#61289
+depends+=(libedit)