summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-01-21 10:10:18 +0100
committerErich Eckner <git@eckner.net>2019-01-21 10:10:18 +0100
commit110c12613a8ad230c4afb0e699a1e835f1dab6d0 (patch)
tree507cb051a987308f4387b427029c84093cbca1be /community
parent826946fc5850f99f21151d575e3d01c2180c8881 (diff)
parentc05ab685e3c48fa8613597a0f0ded93adab6914d (diff)
downloadpackages-110c12613a8ad230c4afb0e699a1e835f1dab6d0.tar.xz
Merge branch 'master' into i486
Diffstat (limited to 'community')
-rw-r--r--community/calibre/PKGBUILD7
-rw-r--r--community/dovecot/PKGBUILD3
-rw-r--r--community/dovecot/dovecot-2.3.4-PRIu64.patch68
-rw-r--r--community/eclipse/PKGBUILD16
-rw-r--r--community/electron2/PKGBUILD16
-rw-r--r--community/electron2/allow-i686.patch14
-rw-r--r--community/teeworlds/PKGBUILD6
7 files changed, 122 insertions, 8 deletions
diff --git a/community/calibre/PKGBUILD b/community/calibre/PKGBUILD
new file mode 100644
index 00000000..add1c241
--- /dev/null
+++ b/community/calibre/PKGBUILD
@@ -0,0 +1,7 @@
+# disable Bonjour testing on build slaves
+eval "$(
+ declare -f check | \
+ sed '
+ s/.*setup.py test/CI=true &/g
+ '
+)"
diff --git a/community/dovecot/PKGBUILD b/community/dovecot/PKGBUILD
new file mode 100644
index 00000000..6a41fea4
--- /dev/null
+++ b/community/dovecot/PKGBUILD
@@ -0,0 +1,3 @@
+# PRI64 instead of lu in sprintfs in tests, already fixed upstream in git
+source+=(dovecot-2.3.4-PRIu64.patch)
+sha256sums+=('699ddd451d7f75a89797f05b910ae81e8cfc0098e11a80e83f3b440894633819')
diff --git a/community/dovecot/dovecot-2.3.4-PRIu64.patch b/community/dovecot/dovecot-2.3.4-PRIu64.patch
new file mode 100644
index 00000000..df85df47
--- /dev/null
+++ b/community/dovecot/dovecot-2.3.4-PRIu64.patch
@@ -0,0 +1,68 @@
+diff -rauN dovecot-2.3.4/src/lib-master/test-event-stats.c dovecot-2.3.4-PRIu64-patch/src/lib-master/test-event-stats.c
+--- dovecot-2.3.4/src/lib-master/test-event-stats.c 2018-11-23 12:06:49.000000000 +0100
++++ dovecot-2.3.4-PRIu64-patch/src/lib-master/test-event-stats.c 2018-12-27 14:35:51.846548380 +0100
+@@ -360,7 +360,7 @@
+ event_unref(&child_ev);
+ test_assert(
+ compare_test_stats_to(
+- "EVENT %lu 1 0 0"
++ "EVENT %"PRIu64" 1 0 0"
+ " stest-event-stats.c %d"
+ " l0 0 ctest2\n", id, l));
+ test_end();
+@@ -386,12 +386,12 @@
+ event_unref(&child_ev);
+ test_assert(
+ compare_test_stats_to(
+- "BEGIN %lu 0 1 0 0"
++ "BEGIN %"PRIu64" 0 1 0 0"
+ " stest-event-stats.c %d ctest1\n"
+- "EVENT %lu 1 1 0"
++ "EVENT %"PRIu64" 1 1 0"
+ " stest-event-stats.c %d"
+ " l1 0 ctest2\n"
+- "END\t%lu\n", idp, lp, idp, l, idp));
++ "END\t%"PRIu64"\n", idp, lp, idp, l, idp));
+ test_end();
+ }
+
+@@ -451,7 +451,7 @@
+ event_unref(&merge_ev2);
+ test_assert(
+ compare_test_stats_to(
+- "EVENT %lu 1 0 0"
++ "EVENT %"PRIu64" 1 0 0"
+ " stest-event-stats.c %d l0 0"
+ " ctest3 ctest2 ctest1 Tkey3"
+ " 10 0 Ikey2 20"
+@@ -483,11 +483,11 @@
+ event_unref(&child_ev);
+ test_assert(
+ compare_test_stats_to(
+- "BEGIN %lu 0 1 0 0"
++ "BEGIN %"PRIu64" 0 1 0 0"
+ " stest-event-stats.c %d ctest1\n"
+- "EVENT %lu 1 3 0 "
++ "EVENT %"PRIu64" 1 3 0 "
+ "stest-event-stats.c %d l3 0"
+- " ctest2\nEND\t%lu\n", id, lp, id, l, id));
++ " ctest2\nEND\t%"PRIu64"\n", id, lp, id, l, id));
+ test_end();
+ }
+
+@@ -525,12 +525,12 @@
+ event_unref(&child2_ev);
+ test_assert(
+ compare_test_stats_to(
+- "BEGIN %lu 0 1 0 0"
++ "BEGIN %"PRIu64" 0 1 0 0"
+ " stest-event-stats.c %d ctest1\n"
+- "EVENT %lu 1 3 0 "
++ "EVENT %"PRIu64" 1 3 0 "
+ "stest-event-stats.c %d l3 0 "
+ "ctest4 ctest5 Tkey3 10 0 Skey4"
+- " str4\nEND\t%lu\n", id, lp, id, l, id));
++ " str4\nEND\t%"PRIu64"\n", id, lp, id, l, id));
+ test_end();
+ }
+
diff --git a/community/eclipse/PKGBUILD b/community/eclipse/PKGBUILD
index c1a4a6db..5da20b19 100644
--- a/community/eclipse/PKGBUILD
+++ b/community/eclipse/PKGBUILD
@@ -1,9 +1,9 @@
# we want the i686 binaries!
-source=("${source[@]/-x86_64/}")
-sha256sums=('70ae1934385b0b7c25e5a76bfcd6d092bfd8d19ce451c3d909afa3cf2448452e'
- 'c33337a1740a84aabec3bd256f4256c8693ab0d1f755c120614bd28ae354f326'
- '6e7b70d73cfe8e7f565465149ddb7d1b4854cba9f3281d370e54c12b1449272d'
- '87ebe3451291a3152eb21bd588ae1ebb06538b62b5f3c5fabec2600accb8adea'
- '59eb59fd362e4daa0b17bb87a2fbb1019dfb86be1546f398055f491c6303476b'
- '09db32c2d958e357b3a959a6860240f3e1eb40f7ffa1815f31661f7f117dd980'
- 'c7c40966c6cecb719f43487476a52e84f86f680fc34d3be7ae535e03be212b4f')
+source_i686=("${source_x86_64[@]/-x86_64/}")
+sha256sums_i686=('70ae1934385b0b7c25e5a76bfcd6d092bfd8d19ce451c3d909afa3cf2448452e'
+ 'c33337a1740a84aabec3bd256f4256c8693ab0d1f755c120614bd28ae354f326'
+ '6e7b70d73cfe8e7f565465149ddb7d1b4854cba9f3281d370e54c12b1449272d'
+ '87ebe3451291a3152eb21bd588ae1ebb06538b62b5f3c5fabec2600accb8adea'
+ '59eb59fd362e4daa0b17bb87a2fbb1019dfb86be1546f398055f491c6303476b'
+ '09db32c2d958e357b3a959a6860240f3e1eb40f7ffa1815f31661f7f117dd980'
+ 'c7c40966c6cecb719f43487476a52e84f86f680fc34d3be7ae535e03be212b4f')
diff --git a/community/electron2/PKGBUILD b/community/electron2/PKGBUILD
new file mode 100644
index 00000000..4f1a6f90
--- /dev/null
+++ b/community/electron2/PKGBUILD
@@ -0,0 +1,16 @@
+source+=('allow-i686.patch')
+sha512sums+=('bce6716f88c0ed7acc72f90ef62f7c4a28b88e98d7fc8dcb6abf545eb6ab7de11e06191618490ed83e7b38b08489063357682ebb909dc952e21cb6dd7b6ddb38')
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ 3 a patch -Np1 -i "${srcdir}"/allow-i686.patch
+ /^}$/ i \
+ find "${srcdir}" \\( '"-name '*.a' -o -name '*.o'"' \\) -delete
+ '
+ declare -f build | \
+ sed '
+ s,/bootstrap.py ,\0--target_arch=ia32 ,
+ s/-t x64/-t ia32/g
+ '
+)"
diff --git a/community/electron2/allow-i686.patch b/community/electron2/allow-i686.patch
new file mode 100644
index 00000000..154ab9bc
--- /dev/null
+++ b/community/electron2/allow-i686.patch
@@ -0,0 +1,14 @@
+--- a/script/update.py
++++ b/script/update.py
+@@ -15,11 +15,6 @@ SOURCE_ROOT = os.path.abspath(os.path.dirname(os.path.dirname(__file__)))
+
+ def main():
+ os.chdir(SOURCE_ROOT)
+-
+- if PLATFORM != 'win32' and platform.architecture()[0] != '64bit':
+- print 'Electron is required to be built on a 64bit machine'
+- return 1
+-
+ update_external_binaries()
+ return update_gyp()
+
diff --git a/community/teeworlds/PKGBUILD b/community/teeworlds/PKGBUILD
new file mode 100644
index 00000000..2dc03c3f
--- /dev/null
+++ b/community/teeworlds/PKGBUILD
@@ -0,0 +1,6 @@
+eval "$(
+ declare -f package | \
+ sed '
+ s@x86_64@x86@g
+ '
+)"