summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-01-15 16:28:28 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2022-01-15 16:28:28 +0100
commit01a4dd2f8fbf7386de0b1b84152425948dd95fec (patch)
treeca19b084b16cc70297274e82ebf9b46221a9d2cb /community
parent48d73fadbe164266506c0572015d07a16143678a (diff)
downloadpackages-01a4dd2f8fbf7386de0b1b84152425948dd95fec.tar.xz
..
Diffstat (limited to 'community')
-rw-r--r--community/ghc/PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/community/ghc/PKGBUILD b/community/ghc/PKGBUILD
index b09d8cf6..3bb526ac 100644
--- a/community/ghc/PKGBUILD
+++ b/community/ghc/PKGBUILD
@@ -1,5 +1,11 @@
# bootstrapping from binary version (when ghc-static is broken)
makedepends=(${makedepends[@]//ghc-static/})
-makedepends_i486+=(ghc92-bin)
-makedepends_i686+=(ghc92-bin)
+makedepends_i486+=(ghc90-bin ncurses5-compat-libs libffi33)
+makedepends_i686+=("${makedepends_i486[@]}")
makedepends_pentium4=("${makedepends_i686[@]}")
+eval "$(
+ declare -f build | \
+ sed '
+ s|./configure|GHC=/usr/bin/ghc-9.0 ./configure|
+ '
+)"