summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--build-support/ghc90-bin/PKGBUILD4
-rw-r--r--community/ghc/PKGBUILD10
2 files changed, 10 insertions, 4 deletions
diff --git a/build-support/ghc90-bin/PKGBUILD b/build-support/ghc90-bin/PKGBUILD
index fedad497..f78e7009 100644
--- a/build-support/ghc90-bin/PKGBUILD
+++ b/build-support/ghc90-bin/PKGBUILD
@@ -5,7 +5,7 @@
# This package can coexist with the latest version of GHC.
# If you would like to compile GHC yourself (AUR: ghc9.0),
# you can use this to bootstrap compilation.
-pkgname=ghc9.0-bin
+pkgname=ghc90-bin
pkgver=9.0.1
pkgrel=1
pkgdesc='Legacy binary GHC 9.0 installed on /usr/bin/ghc-9.0 (Feb/2021 - Feb/2021).'
@@ -21,7 +21,7 @@ provides=('ghc9.0')
conflicts=('ghc9.0')
source=("https://www.haskell.org/ghc/dist/${pkgver}/ghc-${pkgver}-i386-deb9-linux.tar.xz")
noextract=("ghc-${pkgver}-${CARCH}-deb10-linux.tar.xz")
-sha256sums=('c253e7eb62cc9da6524c491c85ec8d3727c2ca6035a8653388e636aaa30a2a0f')
+sha256sums=('880e37cea8328401bcfecfe4bb56eb85195f30135b140140b3f24094264f8ba5')
prepare() {
# for some reason, bsdtar cannot unpack this file:
diff --git a/community/ghc/PKGBUILD b/community/ghc/PKGBUILD
index b09d8cf6..3bb526ac 100644
--- a/community/ghc/PKGBUILD
+++ b/community/ghc/PKGBUILD
@@ -1,5 +1,11 @@
# bootstrapping from binary version (when ghc-static is broken)
makedepends=(${makedepends[@]//ghc-static/})
-makedepends_i486+=(ghc92-bin)
-makedepends_i686+=(ghc92-bin)
+makedepends_i486+=(ghc90-bin ncurses5-compat-libs libffi33)
+makedepends_i686+=("${makedepends_i486[@]}")
makedepends_pentium4=("${makedepends_i686[@]}")
+eval "$(
+ declare -f build | \
+ sed '
+ s|./configure|GHC=/usr/bin/ghc-9.0 ./configure|
+ '
+)"