summaryrefslogtreecommitdiff
path: root/community/python-pip-bootstrap
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-08-30 18:18:52 +0000
committerAndreas Baumann <mail@andreasbaumann.cc>2018-08-30 18:18:52 +0000
commit9753554019c12cc1a9947c21b1d74b464df46e83 (patch)
tree00fec87a39512e055b661e8e70dd09bd0986874c /community/python-pip-bootstrap
parentafb43895ec8d4e1eab1e66eed5d2946f1e1807f8 (diff)
downloadpackages-9753554019c12cc1a9947c21b1d74b464df46e83.tar.xz
community/python-pip-bootstrap
Diffstat (limited to 'community/python-pip-bootstrap')
-rw-r--r--community/python-pip-bootstrap/PKGBUILD26
-rw-r--r--community/python-pip-bootstrap/install.sh4
-rw-r--r--community/python-pip-bootstrap/install2.sh4
3 files changed, 34 insertions, 0 deletions
diff --git a/community/python-pip-bootstrap/PKGBUILD b/community/python-pip-bootstrap/PKGBUILD
new file mode 100644
index 00000000..c2764b6d
--- /dev/null
+++ b/community/python-pip-bootstrap/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Andreas Baumann <mail@andreasbaumann.cc>
+
+pkgname=('python-pip-bootstrap' 'python2-pip-bootstrap')
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="bootstap pip and setuptools for bootstrapping python"
+arch=(i486 'i686' 'x86_64' 'armv6h' 'armv7h')
+url="https://bootstrap.pypa.io/"
+source=("https://bootstrap.pypa.io/get-pip.py")
+sha512sums=('db419d080e0658b656ed9f6ae67adf51a0e2c698c8854b8d589f14756b975985b79be457e845260941519dda7399b027251cb71fe00691df1043260cc3e16d28')
+
+package_python-pip-bootstrap() {
+ depends=('python')
+ install=install.sh
+
+ mkdir -p "${pkgdir}/usr/bin"
+ cp "${srcdir}/get-pip.py" "${pkgdir}/usr/bin/."
+}
+
+package_python2-pip-bootstrap() {
+ depends=('python2')
+ install=install2.sh
+
+ mkdir -p "${pkgdir}/usr/bin"
+ cp "${srcdir}/get-pip.py" "${pkgdir}/usr/bin/get-pip2.py"
+}
diff --git a/community/python-pip-bootstrap/install.sh b/community/python-pip-bootstrap/install.sh
new file mode 100644
index 00000000..e81432e6
--- /dev/null
+++ b/community/python-pip-bootstrap/install.sh
@@ -0,0 +1,4 @@
+post_install() {
+ echo "Bootstrapping python pip, setuptools and wheel.."
+ python /usr/bin/get-pip.py
+}
diff --git a/community/python-pip-bootstrap/install2.sh b/community/python-pip-bootstrap/install2.sh
new file mode 100644
index 00000000..b6aa16fa
--- /dev/null
+++ b/community/python-pip-bootstrap/install2.sh
@@ -0,0 +1,4 @@
+post_install() {
+ echo "Bootstrapping python2 pip, setuptools and wheel.."
+ python2 /usr/bin/get-pip2.py
+}