summaryrefslogtreecommitdiff
path: root/community/python-pip-bootstrap/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/python-pip-bootstrap/PKGBUILD')
-rw-r--r--community/python-pip-bootstrap/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/community/python-pip-bootstrap/PKGBUILD b/community/python-pip-bootstrap/PKGBUILD
new file mode 100644
index 00000000..c2764b6d
--- /dev/null
+++ b/community/python-pip-bootstrap/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Andreas Baumann <mail@andreasbaumann.cc>
+
+pkgname=('python-pip-bootstrap' 'python2-pip-bootstrap')
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="bootstap pip and setuptools for bootstrapping python"
+arch=(i486 'i686' 'x86_64' 'armv6h' 'armv7h')
+url="https://bootstrap.pypa.io/"
+source=("https://bootstrap.pypa.io/get-pip.py")
+sha512sums=('db419d080e0658b656ed9f6ae67adf51a0e2c698c8854b8d589f14756b975985b79be457e845260941519dda7399b027251cb71fe00691df1043260cc3e16d28')
+
+package_python-pip-bootstrap() {
+ depends=('python')
+ install=install.sh
+
+ mkdir -p "${pkgdir}/usr/bin"
+ cp "${srcdir}/get-pip.py" "${pkgdir}/usr/bin/."
+}
+
+package_python2-pip-bootstrap() {
+ depends=('python2')
+ install=install2.sh
+
+ mkdir -p "${pkgdir}/usr/bin"
+ cp "${srcdir}/get-pip.py" "${pkgdir}/usr/bin/get-pip2.py"
+}