summaryrefslogtreecommitdiff
path: root/community/python-distro
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-08-03 14:36:50 +0000
committerAndreas Baumann <mail@andreasbaumann.cc>2018-08-03 14:36:50 +0000
commitf27af5ead386f1ecd1a8c74180f3f844f1dba8b9 (patch)
tree6d245cd74e8286f8edfa98e86b7ddee9d9c7061a /community/python-distro
parent043f74201967addd0353517fa10251975f7c723f (diff)
downloadpackages-f27af5ead386f1ecd1a8c74180f3f844f1dba8b9.tar.xz
i486-specific patches for python modules
Diffstat (limited to 'community/python-distro')
-rw-r--r--community/python-distro/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/python-distro/PKGBUILD b/community/python-distro/PKGBUILD
new file mode 100644
index 00000000..32d99307
--- /dev/null
+++ b/community/python-distro/PKGBUILD
@@ -0,0 +1,30 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # disable sphinx for now, needs too many packages
+ makedepends=(${makedepends[@]//python-sphinx/})
+ makedepends=(${makedepends[@]//python2-sphinx/})
+
+ eval "$(
+ declare -f build | \
+ sed '
+ s/make man SPHINXBUILD=sphinx-build2//
+ s/make man SPHINXBUILD=sphinx-build//
+ '
+ )"
+
+ eval "$(
+ declare -f package_python-distro | \
+ sed '
+ /install.*man.*ld.1/d
+ '
+ )"
+
+ eval "$(
+ declare -f package_python2-distro | \
+ sed '
+ /install.*man.*ld.1/d
+ '
+ )"
+
+ unset check
+fi