summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--community/python-apipkg/PKGBUILD4
-rw-r--r--community/python-atomicwrites/PKGBUILD4
-rw-r--r--community/python-cachecontrol/PKGBUILD4
-rw-r--r--community/python-distlib/PKGBUILD5
-rw-r--r--community/python-distro/PKGBUILD30
-rw-r--r--community/python-html5lib/PKGBUILD4
-rw-r--r--community/python-iniconfig/PKGBUILD4
-rw-r--r--community/python-lockfile/PKGBUILD5
-rw-r--r--community/python-mock/PKGBUILD5
-rw-r--r--community/python-msgpack/PKGBUILD4
-rw-r--r--community/python-pbr/PKGBUILD4
-rw-r--r--community/python-pluggy/PKGBUILD4
-rw-r--r--community/python-py/PKGBUILD4
-rw-r--r--community/python-pytest/PKGBUILD5
-rw-r--r--community/python-setuptools-scm/PKGBUILD4
-rw-r--r--community/python-webencodings/PKGBUILD4
-rw-r--r--community/python2-funcsigs/PKGBUILD4
-rw-r--r--extra/pyopenssl/PKGBUILD5
-rw-r--r--extra/python-attrs/PKGBUILD4
-rw-r--r--extra/python-cffi/PKGBUILD4
-rw-r--r--extra/python-cryptography/PKGBUILD4
-rw-r--r--extra/python-packaging/PKGBUILD4
-rw-r--r--extra/python-pip/PKGBUILD13
-rw-r--r--extra/python-pyparsing/PKGBUILD51
-rw-r--r--extra/python-requests/PKGBUILD4
-rw-r--r--extra/python-setuptools/PKGBUILD4
-rw-r--r--extra/python-six/PKGBUILD4
-rw-r--r--extra/python-urllib3/PKGBUILD16
28 files changed, 211 insertions, 0 deletions
diff --git a/community/python-apipkg/PKGBUILD b/community/python-apipkg/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/community/python-apipkg/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/community/python-atomicwrites/PKGBUILD b/community/python-atomicwrites/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/community/python-atomicwrites/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/community/python-cachecontrol/PKGBUILD b/community/python-cachecontrol/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/community/python-cachecontrol/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/community/python-distlib/PKGBUILD b/community/python-distlib/PKGBUILD
new file mode 100644
index 00000000..870e034f
--- /dev/null
+++ b/community/python-distlib/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # currently tests are failing, they are disabled not due to dependencies
+ unset check
+fi
diff --git a/community/python-distro/PKGBUILD b/community/python-distro/PKGBUILD
new file mode 100644
index 00000000..32d99307
--- /dev/null
+++ b/community/python-distro/PKGBUILD
@@ -0,0 +1,30 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # disable sphinx for now, needs too many packages
+ makedepends=(${makedepends[@]//python-sphinx/})
+ makedepends=(${makedepends[@]//python2-sphinx/})
+
+ eval "$(
+ declare -f build | \
+ sed '
+ s/make man SPHINXBUILD=sphinx-build2//
+ s/make man SPHINXBUILD=sphinx-build//
+ '
+ )"
+
+ eval "$(
+ declare -f package_python-distro | \
+ sed '
+ /install.*man.*ld.1/d
+ '
+ )"
+
+ eval "$(
+ declare -f package_python2-distro | \
+ sed '
+ /install.*man.*ld.1/d
+ '
+ )"
+
+ unset check
+fi
diff --git a/community/python-html5lib/PKGBUILD b/community/python-html5lib/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/community/python-html5lib/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/community/python-iniconfig/PKGBUILD b/community/python-iniconfig/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/community/python-iniconfig/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/community/python-lockfile/PKGBUILD b/community/python-lockfile/PKGBUILD
new file mode 100644
index 00000000..e50d2ff2
--- /dev/null
+++ b/community/python-lockfile/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pbr' 'python2-pbr')
+ unset check
+fi
diff --git a/community/python-mock/PKGBUILD b/community/python-mock/PKGBUILD
new file mode 100644
index 00000000..e50d2ff2
--- /dev/null
+++ b/community/python-mock/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pbr' 'python2-pbr')
+ unset check
+fi
diff --git a/community/python-msgpack/PKGBUILD b/community/python-msgpack/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/community/python-msgpack/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/community/python-pbr/PKGBUILD b/community/python-pbr/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/community/python-pbr/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/community/python-pluggy/PKGBUILD b/community/python-pluggy/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/community/python-pluggy/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/community/python-py/PKGBUILD b/community/python-py/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/community/python-py/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/community/python-pytest/PKGBUILD b/community/python-pytest/PKGBUILD
new file mode 100644
index 00000000..6c63d86f
--- /dev/null
+++ b/community/python-pytest/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-setuptools-scm' 'python2-setuptools-scm')
+ unset check
+fi
diff --git a/community/python-setuptools-scm/PKGBUILD b/community/python-setuptools-scm/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/community/python-setuptools-scm/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/community/python-webencodings/PKGBUILD b/community/python-webencodings/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/community/python-webencodings/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/community/python2-funcsigs/PKGBUILD b/community/python2-funcsigs/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/community/python2-funcsigs/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/extra/pyopenssl/PKGBUILD b/extra/pyopenssl/PKGBUILD
new file mode 100644
index 00000000..aa4776cc
--- /dev/null
+++ b/extra/pyopenssl/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
+unset -f pkgver
diff --git a/extra/python-attrs/PKGBUILD b/extra/python-attrs/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/extra/python-attrs/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/extra/python-cffi/PKGBUILD b/extra/python-cffi/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/extra/python-cffi/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/extra/python-cryptography/PKGBUILD b/extra/python-cryptography/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/extra/python-cryptography/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/extra/python-packaging/PKGBUILD b/extra/python-packaging/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/extra/python-packaging/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/extra/python-pip/PKGBUILD b/extra/python-pip/PKGBUILD
new file mode 100644
index 00000000..f1880e74
--- /dev/null
+++ b/extra/python-pip/PKGBUILD
@@ -0,0 +1,13 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ md5sums[1]='71cb8b43efaa6af0d6cd98576ca2f932'
+ sha256sums[1]='ff81c9d48be20765145cb04953c54c5b9059bd193e3d82cec870d3391e6e6dd1'
+
+ # disable sphinx for now, needs too many packages
+ makedepends=(${makedepends[@]//python-sphinx/})
+ makedepends=(${makedepends[@]//python2-sphinx/})
+
+ unset check
+fi
+
+
diff --git a/extra/python-pyparsing/PKGBUILD b/extra/python-pyparsing/PKGBUILD
new file mode 100644
index 00000000..7f88e0ac
--- /dev/null
+++ b/extra/python-pyparsing/PKGBUILD
@@ -0,0 +1,51 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # subversion introduces a crazy amount of build dependencies, take
+ # official tarball
+ makedepends=(${makedepends[@]//subversion/})
+ source=('https://pypi.python.org/packages/3c/ec/a94f8cf7274ea60b5413df054f82a8980523efd712ec55a59e7c3357cf7c/pyparsing-2.2.0.tar.gz')
+
+ eval "$(
+ declare -f prepare | \
+ sed '
+ s/pyparsing_$pkgver/pyparsing-$pkgver/g
+ s,pyparsing-$pkgver/src,pyparsing-$pkgver,g
+ s,pyparsing-$pkgver-py2/src,pyparsing-$pkgver-py2,g
+ /sed/d
+ '
+ )"
+
+ eval "$(
+ declare -f build | \
+ sed '
+ s/pyparsing_$pkgver/pyparsing-$pkgver/g
+ s,pyparsing-$pkgver/src,pyparsing-$pkgver,g
+ s,pyparsing-$pkgver-py2/src,pyparsing-$pkgver-py2,g
+ '
+ )"
+
+ eval "$(
+ declare -f package_python-pyparsing | \
+ sed '
+ s/pyparsing_$pkgver/pyparsing-$pkgver/g
+ s,pyparsing-$pkgver/src,pyparsing-$pkgver,g
+ '
+ )"
+
+ eval "$(
+ declare -f package_python2-pyparsing | \
+ sed '
+ s/pyparsing_$pkgver/pyparsing-$pkgver/g
+ s,pyparsing-$pkgver-py2/src,pyparsing-$pkgver-py2,g
+ '
+ )"
+
+ # needed?
+ # remove a really weird sed
+ #sed -i 's/sed/#sed/g' PKGBUILD
+
+ unset check
+fi
+
+
+
diff --git a/extra/python-requests/PKGBUILD b/extra/python-requests/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/extra/python-requests/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/extra/python-setuptools/PKGBUILD b/extra/python-setuptools/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/extra/python-setuptools/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/extra/python-six/PKGBUILD b/extra/python-six/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/extra/python-six/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/extra/python-urllib3/PKGBUILD b/extra/python-urllib3/PKGBUILD
new file mode 100644
index 00000000..f7e86cb1
--- /dev/null
+++ b/extra/python-urllib3/PKGBUILD
@@ -0,0 +1,16 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # disable sphinx for now, needs too many packages
+ makedepends=(${makedepends[@]//python2-sphinx/})
+
+ eval "$(
+ declare -f build | \
+ sed '
+ /make.*html/d
+ '
+ )"
+
+ pkgname=(${pkgname[@]//python-urllib3-doc})
+
+ unset check
+fi