summaryrefslogtreecommitdiff
path: root/community/embree/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-06-22 17:07:35 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2018-06-22 17:07:35 +0200
commitff954ca5d7107235ce795425d0dbe15e03ab16e5 (patch)
tree23a5f309210922aadb3f615f13a7cbfc66bfc418 /community/embree/PKGBUILD
parent2eaefdd0fa39b29e40bfb1d6ebb88503f79e0a2f (diff)
downloadpackages-ff954ca5d7107235ce795425d0dbe15e03ab16e5.tar.xz
community/embree: increased max ISA to SSE4.2
Diffstat (limited to 'community/embree/PKGBUILD')
-rw-r--r--community/embree/PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/community/embree/PKGBUILD b/community/embree/PKGBUILD
index 8d2043c8..ee543197 100644
--- a/community/embree/PKGBUILD
+++ b/community/embree/PKGBUILD
@@ -1,9 +1,13 @@
# avoid breakage in newer CPU ISAs, supporting SSE2 should be enough for
# 32-bit platforms
+# for special use cases (like running Archlinux32 on 64-bit hardware)
+# we can support up to SSE4.2 (everything above is too hard to fix).
+# As Embree chooses the ISA at runtime, this is no problem for machines
+# not having SSE4.2
eval "$(
declare -f build | \
sed '
- /cmake/s/-DEMBREE_MAX_ISA="AVX512SKX"/-DEMBREE_MAX_ISA="SSE2"/
+ /cmake/s/-DEMBREE_MAX_ISA="AVX512SKX"/-DEMBREE_MAX_ISA="SSE4.2"/
'
)"