summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--community/embree/PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/community/embree/PKGBUILD b/community/embree/PKGBUILD
index 8d2043c8..ee543197 100644
--- a/community/embree/PKGBUILD
+++ b/community/embree/PKGBUILD
@@ -1,9 +1,13 @@
# avoid breakage in newer CPU ISAs, supporting SSE2 should be enough for
# 32-bit platforms
+# for special use cases (like running Archlinux32 on 64-bit hardware)
+# we can support up to SSE4.2 (everything above is too hard to fix).
+# As Embree chooses the ISA at runtime, this is no problem for machines
+# not having SSE4.2
eval "$(
declare -f build | \
sed '
- /cmake/s/-DEMBREE_MAX_ISA="AVX512SKX"/-DEMBREE_MAX_ISA="SSE2"/
+ /cmake/s/-DEMBREE_MAX_ISA="AVX512SKX"/-DEMBREE_MAX_ISA="SSE4.2"/
'
)"