summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorAlastair Hughes <hobbitalastair@gmail.com>2017-08-12 09:15:33 +1200
committerAllan McRae <allan@archlinux.org>2017-09-14 13:03:44 +1000
commit62bfba53dbb33d12f3a4beaf9044a04b40c6b537 (patch)
tree0f0179a8c8abe4d7709771c36820c5b85b9e08c8 /scripts/Makefile.am
parent2ddbc6964b31f65678ed8e7c2cf1e80f0a7d4a0f (diff)
downloadpacman-62bfba53dbb33d12f3a4beaf9044a04b40c6b537.tar.xz
Make the flags used for sed -i configurable
Not all sed implementations on linux accept the --follow-symlinks argument, so let the user configure the arguments passed to sed if required. Signed-off-by: Alastair Hughes <hobbitalastair@gmail.com> [Allan: fixed configure summary output] Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 4bb08a24..86e44cb6 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -152,7 +152,8 @@ edit = sed \
-e "s|@OWNERCMD[@]|$(OWNERCMD)|g" \
-e "s|@MODECMD[@]|$(MODECMD)|g" \
-e 's|@SIZECMD[@]|$(SIZECMD)|g' \
- -e 's|@SEDINPLACE[@]|$(SEDINPLACE)|g' \
+ -e 's|@SEDINPLACEFLAGS[@]|$(SEDINPLACEFLAGS)|g' \
+ -e 's|@SEDPATH[@]|$(SEDPATH)|g' \
-e 's|@DUFLAGS[@]|$(DUFLAGS)|g' \
-e 's|@DUPATH[@]|$(DUPATH)|g' \
-e 's|@SCRIPTNAME[@]|$@|g' \