summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorQue Quotion <quequotion@gmail.com>2018-11-27 18:23:02 +0900
committerAllan McRae <allan@archlinux.org>2018-11-27 22:48:43 +1000
commit508b4e3ec0cb3e365942f4dc0626edda4789932b (patch)
treed47fd87b0ba310da989e45423180c4fda2610957 /scripts/Makefile.am
parent0bb04fa16a82db133dd010478c1256bc8500c5e7 (diff)
downloadpacman-508b4e3ec0cb3e365942f4dc0626edda4789932b.tar.xz
Split prepare_buildenv() to libmakepkg
This opens the door for third parties to provide libmakepkg extentions for the purpose of altering the build environment. Signed-off-by: Que Quotion <quequotion@gmail.com> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index b4c53953..dc2d8e5e 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -40,6 +40,7 @@ LIBRARY = \
libmakepkgdir = $(datarootdir)/makepkg
LIBMAKEPKGDIRS = \
+ buildenv \
executable \
integrity \
lint_config \
@@ -61,6 +62,11 @@ LIBMAKEPKG_IN = \
libmakepkg/executable/strip.sh \
libmakepkg/executable/sudo.sh \
libmakepkg/executable/vcs.sh \
+ libmakepkg/buildenv.sh \
+ libmakepkg/buildenv/buildflags.sh \
+ libmakepkg/buildenv/compiler.sh \
+ libmakepkg/buildenv/debugflags.sh \
+ libmakepkg/buildenv/makeflags.sh \
libmakepkg/integrity.sh \
libmakepkg/integrity/generate_checksum.sh \
libmakepkg/integrity/generate_signature.sh \