summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorQue Quotion <quequotion@gmail.com>2018-11-27 18:23:00 +0900
committerAllan McRae <allan@archlinux.org>2018-11-27 22:48:43 +1000
commit0bb04fa16a82db133dd010478c1256bc8500c5e7 (patch)
tree21ca195cdffbe3f1315b25a3b16bd1366d556941 /scripts/Makefile.am
parentd81b5cc2a5193a344fc6f9cbf72d406d5597d85b (diff)
downloadpacman-0bb04fa16a82db133dd010478c1256bc8500c5e7.tar.xz
Split check_software() to libmakepkg
This opens the door for third parties who provide extensions to libmakepkg to supply scripts that confirm the presence of their dependant executables. Signed-off-by: Que Quotion <quequotion@gmail.com> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 26c2e10d..b4c53953 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -40,6 +40,7 @@ LIBRARY = \
libmakepkgdir = $(datarootdir)/makepkg
LIBMAKEPKGDIRS = \
+ executable \
integrity \
lint_config \
lint_package \
@@ -49,6 +50,17 @@ LIBMAKEPKGDIRS = \
util
LIBMAKEPKG_IN = \
+ libmakepkg/executable.sh \
+ libmakepkg/executable/ccache.sh \
+ libmakepkg/executable/checksum.sh \
+ libmakepkg/executable/distcc.sh \
+ libmakepkg/executable/fakeroot.sh \
+ libmakepkg/executable/gpg.sh \
+ libmakepkg/executable/gzip.sh \
+ libmakepkg/executable/pacman.sh \
+ libmakepkg/executable/strip.sh \
+ libmakepkg/executable/sudo.sh \
+ libmakepkg/executable/vcs.sh \
libmakepkg/integrity.sh \
libmakepkg/integrity/generate_checksum.sh \
libmakepkg/integrity/generate_signature.sh \