summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
Diffstat (limited to 'extra')
-rw-r--r--extra/soundtouch/PKGBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/extra/soundtouch/PKGBUILD b/extra/soundtouch/PKGBUILD
index 0ea408f9..9c36c6d3 100644
--- a/extra/soundtouch/PKGBUILD
+++ b/extra/soundtouch/PKGBUILD
@@ -1,11 +1,18 @@
# hotfix for changed git repo (already fixed upstream in staging)
source[0]="git+https://codeberg.org/soundtouch/soundtouch.git#tag=${_tag}"
+# configure handles SSE/MMX/etc. but cmake support is somewhat simpler
+# setting flags for disabling optimiazations by hand (and also do the
+# configure stuff, just in case)
if [ "$CARCH" = 'i486' -o "$CARCH" = 'i686' ]; then
eval "$(
declare -f prepare | \
sed '
s|./configure|./configure --disable-x86-optimizations|g
'
+ declare -f build | \
+ sed '
+ s|cmake |CXXFLAGS=-DSOUNDTOUCH_DISABLE_X86_OPTIMIZATIONS cmake |
+ '
)"
fi